pptpd: use boolean options
authorVladislav Grigoryev <vg.aetera@gmail.com>
Fri, 3 Nov 2023 08:36:10 +0000 (11:36 +0300)
committerTianling Shen <cnsztl@gmail.com>
Tue, 7 Nov 2023 01:51:12 +0000 (09:51 +0800)
Use boolean options and fix the relevant init error.

Signed-off-by: Vladislav Grigoryev <vg.aetera@gmail.com>
net/pptpd/Makefile
net/pptpd/files/pptpd.init

index 6c90f4f492b74153d6c020b74a47fd0659083e8d..4892a3e9b06949ba6c7d0b814e337db3a617c46c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
 PKG_VERSION:=1.4.0
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/poptop
index 322eaaf1b5ef3f0db786a1caab4cc1ce41653429..ae39c0fd577ef432fee4e9a2355363bd73b14213 100644 (file)
@@ -18,11 +18,11 @@ validate_login_section() {
 
 validate_pptpd_section() {
        uci_load_validate pptpd service "$1" "$2" \
-               'enabled:uinteger' \
+               'enabled:bool:1' \
                'localip:string' \
                'remoteip:string' \
                'mppe:list(string):required no40 no56 stateless' \
-               'logwtmp:uinteger'
+               'logwtmp:bool:0'
 }
 
 setup_login() {