tgt: Update to 1.0.86
authorTianling Shen <cnsztl@immortalwrt.org>
Wed, 17 May 2023 08:24:49 +0000 (16:24 +0800)
committerTianling Shen <cnsztl@gmail.com>
Thu, 18 May 2023 08:36:53 +0000 (16:36 +0800)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so
just having _GNU_SOURCE defined is not enough anymore.

Manually pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
net/tgt/Makefile

index 46720dddfccb43117a68f31b34425a39d9bf0290..8939d51d19e69f967b4e1d90fe66018bf1320971 100644 (file)
@@ -4,12 +4,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tgt
-PKG_VERSION:=1.0.83
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.86
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/fujita/tgt/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=a9ddb0ff32d3396416df9639f9f398d14a6051f505b5772d7d196df99df8b8da
+PKG_HASH:=af84c16bf8893d65666afcc0424b46dafddd2d0e5dcf818b319ea9ed3c3315a7
 
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
 PKG_LICENSE:=GPL-2.0-only
@@ -35,6 +35,10 @@ supports multiple methods for accessing block storage. Tgt consists of
 user-space daemon and tools.
 endef
 
+ifneq ($(CONFIG_USE_MUSL),)
+  TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
+endif
+
 define Build/Compile
        $(call Build/Compile/Default,programs)
 endef