open-vm-tools: enable deploypkg plugin
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 15 Feb 2021 12:01:30 +0000 (13:01 +0100)
committerRosen Penev <rosenp@gmail.com>
Thu, 22 Sep 2022 08:29:04 +0000 (01:29 -0700)
Enable support functions for guest package deployment.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/open-vm-tools/Makefile
utils/open-vm-tools/files/telinit [new file with mode: 0644]

index 406fe6e4b0655e805dd86c4f8797e1e1c63f1c07..72b1f4dfe4f924e54d4728b80ff5f8c761528f53 100644 (file)
@@ -35,7 +35,11 @@ endef
 
 define Package/open-vm-tools
 $(call Package/open-vm-tools/Default)
-  DEPENDS:=@TARGET_x86 +glib2 +libpthread +libtirpc
+  DEPENDS:=@TARGET_x86 \
+       +glib2 \
+       +libpthread \
+       +libtirpc \
+       +libmspack
   TITLE:=open-vm-tools
   URL:=https://github.com/vmware/open-vm-tools
   MAINTAINER:=Yuhei OKAWA <tochiro.srchack@gmail.com>
@@ -68,7 +72,6 @@ CONFIGURE_ARGS+= \
        --without-pam \
        --disable-grabbitmqproxy \
        --disable-vgauth \
-       --disable-deploypkg \
        --without-root-privileges \
        --without-kernel-modules \
        --without-dnet \
@@ -105,11 +108,13 @@ define Package/open-vm-tools/install
 
        $(INSTALL_DIR) $(1)/sbin/
        $(INSTALL_BIN) ./files/shutdown $(1)/sbin/
+       $(INSTALL_BIN) ./files/telinit $(1)/sbin/
 
        $(INSTALL_DIR) $(1)/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libguestlib.so* $(1)/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhgfs.so* $(1)/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvmtools.so* $(1)/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libDeployPkg.so* $(1)/lib/
 
        $(INSTALL_DIR) $(1)/usr/lib/open-vm-tools/plugins/common/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/common/libhgfsServer.so $(1)/usr/lib/open-vm-tools/plugins/common/
@@ -120,6 +125,7 @@ define Package/open-vm-tools/install
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libpowerOps.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libtimeSync.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libvmbackup.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/open-vm-tools/plugins/vmsvc/libdeployPkgPlugin.so $(1)/usr/lib/open-vm-tools/plugins/vmsvc/
 
        $(INSTALL_DIR) $(1)/etc/hotplug.d/block/
        $(INSTALL_BIN) ./files/vmware-scsi.hotplug $(1)/etc/hotplug.d/block/80-vmware-scsi
diff --git a/utils/open-vm-tools/files/telinit b/utils/open-vm-tools/files/telinit
new file mode 100644 (file)
index 0000000..3fa1c3c
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+#compatibility script for traditional customization
+
+/sbin/reboot