omap: switch default kernel to 5.15
authorAlexey Smirnov <s.alexey@gmail.com>
Mon, 19 Dec 2022 10:32:58 +0000 (13:32 +0300)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 12 May 2023 11:02:39 +0000 (13:02 +0200)
Switch to kernel 5.15 although it is marked as source only. It is marked
as source only because the eth0 interface can't be added to the br-lan
default interface resulting in a broken ethernet [0]. There is a
workaround to set a higher pvd (e.g. to 4000) in the dts [1].

Other functionality was already tested on a Beaglebone Black for
+6month now without issues.

Merging this is important to finally branch a new release. We want to
get rid completely of 5.10 kernel. Without this commit we get following
error: "Missing kernel version/hash file for 5.10." Hopfully someone
will fix the board in the rc phase.

- [0] https://github.com/openwrt/openwrt/issues/11953
- [1] https://github.com/openwrt/openwrt/issues/11953#issuecomment-1419078990

Signed-off-by: Alexey Smirnov <s.alexey@gmail.com>
[rewrite commit message]
Signed-off-by: Nick Hainke <vincent@systemli.org>
target/linux/omap/Makefile

index 6dc1565f06348ec4067ed71802505e81eb3e8cd6..f995b5eae4dc25aae323248b02c79b8057cb52ec 100644 (file)
@@ -12,8 +12,7 @@ CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 SUBTARGETS:=generic
 
-KERNEL_PATCHVER:=5.10
-KERNEL_TESTING_PATCHVER:=5.15
+KERNEL_PATCHVER:=5.15
 
 KERNELNAME:=zImage dtbs