correct tar link
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Jan 2012 16:43:40 +0000 (16:43 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Jan 2012 16:43:40 +0000 (16:43 +0000)
When we create the /bin/tar in $(IPKG_INSTROOT) link we want it to point to
/usr/bin/tar, and not to $(IPKG_INSTROOT)/usr/bin/tar as $(IPKG_INSTROOT)
is certainly not a valid path on the built rootfs.

Signed-off-by: Emmanuel Deloget <logout@free.fr>
SVN-Revision: 29813

utils/tar/Makefile

index cae11d98573e4d9a1dd17d8f513b261696a4adda..7f346f64f2aa10b6e0d90930bd7fad4cd071d835 100644 (file)
@@ -37,7 +37,7 @@ define Package/tar/postinst
 if [ -e $${IPKG_INSTROOT}/bin/tar ]; then
   rm -r $${IPKG_INSTROOT}/bin/tar;
 fi
-ln -sf $${IPKG_INSTROOT}/usr/bin/tar $${IPKG_INSTROOT}/bin/tar
+ln -sf /usr/bin/tar $${IPKG_INSTROOT}/bin/tar
 endef
 
 define Package/tar/postrm