ibrdtn: Disable dependency on glib-2.0 library
authorJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Sun, 24 Aug 2014 09:17:07 +0000 (11:17 +0200)
committerJohannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Sun, 24 Aug 2014 09:59:06 +0000 (11:59 +0200)
Since the current release of the package does not provide a
configure option to disable this dependency, a patch is necessary
to add this option.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
libs/ibrdtn/Makefile
libs/ibrdtn/patches/100-add_configure_options.patch [new file with mode: 0644]

index eb0f07cbb0e257c855e95d32fb9f29a02ff022ca..2c023f9ca9f62be86f2bb03ab936e57d69293915 100644 (file)
@@ -34,7 +34,8 @@ define Package/ibrdtn/description
 endef
 
 CONFIGURE_ARGS += \
-       --with-compression
+       --with-compression \
+       --without-glib
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)
diff --git a/libs/ibrdtn/patches/100-add_configure_options.patch b/libs/ibrdtn/patches/100-add_configure_options.patch
new file mode 100644 (file)
index 0000000..9a8df8d
--- /dev/null
@@ -0,0 +1,33 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -159,12 +159,21 @@ AS_IF([test "x$enable_android" = "xyes"], [
+       dnl -----------------------------------------------
+       dnl check for glib support
+       dnl -----------------------------------------------
+-      PKG_CHECK_MODULES([GLIB], [glib-2.0], [
+-              AC_SUBST(GLIB_CFLAGS)
+-              AC_SUBST(GLIB_LIBS)
+-              AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
+-              REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
+-      ], [
++      AC_ARG_WITH([glib], [AS_HELP_STRING([--without-glib], [Disable linking to glib-2.0 library])], [with_glib=no], [with_glib=yes])
++      AS_IF([test "x$with_glib" != xno],
++      [
++              PKG_CHECK_MODULES([GLIB], [glib-2.0], [
++                      AC_SUBST(GLIB_CFLAGS)
++                      AC_SUBST(GLIB_LIBS)
++                      AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
++                      REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
++              ], [
++                      with_glib=no
++              ])
++      ], [])
++              
++      AS_IF([test "x$with_glib" = xno],
++      [
+               AS_IF([test "x$has_endian_h" = "xyes"],[
+                       AC_MSG_NOTICE([use endian.h for endianess conversion])
+               ],[
+-- 
+1.9.1
+