autoconf: fix shebang
authorRen Zongjia <acooler15@foxmail.com>
Sun, 12 Sep 2021 09:31:21 +0000 (17:31 +0800)
committerRosen Penev <rosenp@gmail.com>
Sun, 12 Sep 2021 17:57:29 +0000 (10:57 -0700)
Fix shebang errors for autom4te, autoreconf, autoheader, autoscan, autoupdate, ifnames.

resolve openwrt/packages#16604

Signed-off-by: Ren Zongjia <acooler15@foxmail.com>
devel/autoconf/Makefile
devel/autoconf/test.sh [new file with mode: 0644]

index c7a9d757712f9b8f74d2effa19e205fb2f769940..8d6ff7d15dc75ac1b745867b91da8f66dde1145b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=autoconf
 PKG_VERSION:=2.70
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=@GNU/autoconf
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -39,9 +39,12 @@ endef
 
 CONFIGURE_VARS += M4=m4 EMACS=no
 
+FIX_PATHS = $(SED) '1c \#!/usr/bin/perl' -e 's| /[^ ]*/bin/perl| /usr/bin/perl|g'
+
 define Package/autoconf/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       grep -rEl "#\!.*perl" $(1)/usr/bin/ | xargs $(FIX_PATHS)
        $(INSTALL_DIR) $(1)/usr/share/autoconf
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/autoconf/INSTALL \
        $(1)/usr/share/autoconf/
diff --git a/devel/autoconf/test.sh b/devel/autoconf/test.sh
new file mode 100644 (file)
index 0000000..6a3b950
--- /dev/null
@@ -0,0 +1,8 @@
+#!/bin/sh
+autoconf --version | grep $2 && \
+autoheader --version | grep $2 && \
+autom4te --version | grep $2 && \
+autoreconf --version | grep $2 && \
+autoscan --version | grep $2 && \
+autoupdate --version | grep $2 && \
+ifnames --version | grep $2