fix HAVE_ISC_READER related error
authorFelix Fietkau <nbd@openwrt.org>
Sun, 3 Sep 2006 18:11:10 +0000 (18:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 3 Sep 2006 18:11:10 +0000 (18:11 +0000)
SVN-Revision: 4742

openwrt/package/dnsmasq/Makefile

index f6c2d36c52b53040708390d52db3e0514942c635..2208a06ce4244eb099c195cde208eeb63ac8b35f 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.32
+PKG_VERSION:=2.33
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=d1f593a8352db1d6ad3dccc9b775295d
+PKG_MD5SUM:=45696461b6e6bc929273b1191ca50447
 PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
@@ -37,6 +37,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
                all
 endef