zmq: update to 4.1.3, fix GCC5 error, refresh patches 2086/head
authorTed Hess <thess@kitschensync.net>
Mon, 7 Dec 2015 17:07:06 +0000 (12:07 -0500)
committerTed Hess <thess@kitschensync.net>
Mon, 7 Dec 2015 17:07:06 +0000 (12:07 -0500)
Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/zmq/Makefile
libs/zmq/patches/010-disable_pedantic_on_linux_with_ulibc++.patch
libs/zmq/patches/020-map_with_const_string_with_ublic++.patch
libs/zmq/patches/030-streamoff_missing_with_ulibc++.patch
libs/zmq/patches/040-fix_GNUC_conditional_for_GCC5.patch [new file with mode: 0644]
libs/zmq/patches/100-fix-cxx-include-order.patch

index ab07dc1e1478d5b6653d79c0b7a28fafb60179d5..86f2a2d7eb092e9c45238eb27e3be44a81f46b66 100644 (file)
@@ -10,7 +10,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zeromq
-PKG_VERSION:=4.1.1
+PKG_VERSION:=4.1.3
 PKG_RELEASE:=1
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
 PKG_LICENSE:=GPL-3.0+
@@ -18,7 +18,7 @@ PKG_LICENSE_FILES:=LICENCE.txt
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= http://download.zeromq.org
-PKG_MD5SUM:=0a4b44aa085644f25c177f79dc13f253
+PKG_MD5SUM:=d0824317348cfb44b8692e19cc73dc3a
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libuuid
index 74e673c1acdbddae9670c3966777bc917b86ff14..f7ecc489ef6becfe0cf9629222fb0dea0f2d4b95 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -147,8 +147,10 @@ case "${host_os}" in
+@@ -148,8 +148,10 @@ case "${host_os}" in
      *linux*)
          # Define on Linux to enable all library features. Define if using a gnu compiler
          if test "x$GXX" = "xyes"; then
index 121f7070140991dc512422de417a8870caf3f26e..3e13e272f233642e8f3549b5aaee6940794cc2fa 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/metadata.hpp
 +++ b/src/metadata.hpp
-@@ -31,7 +31,7 @@ namespace zmq
+@@ -41,7 +41,7 @@ namespace zmq
      {
          public:
  
@@ -11,7 +11,7 @@
              virtual ~metadata_t ();
 --- a/src/socket_base.cpp
 +++ b/src/socket_base.cpp
-@@ -20,6 +20,7 @@
+@@ -30,6 +30,7 @@
  #include <new>
  #include <string>
  #include <algorithm>
@@ -21,7 +21,7 @@
  
 --- a/src/stream_engine.cpp
 +++ b/src/stream_engine.cpp
-@@ -198,7 +198,7 @@ void zmq::stream_engine_t::plug (io_thre
+@@ -208,7 +208,7 @@ void zmq::stream_engine_t::plug (io_thre
              //  Compile metadata.
              typedef metadata_t::dict_t properties_t;
              properties_t properties;
@@ -30,7 +30,7 @@
              zmq_assert (metadata == NULL);
              metadata = new (std::nothrow) metadata_t (properties);
          }
-@@ -805,7 +805,7 @@ void zmq::stream_engine_t::mechanism_rea
+@@ -815,7 +815,7 @@ void zmq::stream_engine_t::mechanism_rea
  
      //  If we have a peer_address, add it to metadata
      if (!peer_address.empty()) {
index 6abd647ae376ddf64322e5b5b9499bdffa595582..8c137c8c541dd62b01dd886f4fbb4141bf70a62c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/blob.hpp
 +++ b/src/blob.hpp
-@@ -21,6 +21,7 @@
+@@ -31,6 +31,7 @@
  #define __ZMQ_BLOB_HPP_INCLUDED__
  
  #include <string>
diff --git a/libs/zmq/patches/040-fix_GNUC_conditional_for_GCC5.patch b/libs/zmq/patches/040-fix_GNUC_conditional_for_GCC5.patch
new file mode 100644 (file)
index 0000000..dea9b48
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/blob.hpp
++++ b/src/blob.hpp
+@@ -38,7 +38,7 @@
+ // They seem to be doing something for MSC, but since I only have gcc, I'll just do that
+ // Assuming this is uneccessary on GCC 4
+ // #if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
+-#if (defined(__GNUC__) && (__GNUC__ >= 3) && (__GNUC__ <= 4))
++#if (defined(__GNUC__) && (__GNUC__ >= 3))
+ namespace std
+ {
+   template<>
index 63a21ba1f67a269e1382756c11b511521906bd5b..120e96595827829b63fe3b8d2c5c2fced0f19386 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/mtrie.cpp
 +++ b/src/mtrie.cpp
-@@ -17,11 +17,11 @@
+@@ -27,11 +27,11 @@
      along with this program.  If not, see <http://www.gnu.org/licenses/>.
  */
  
@@ -16,7 +16,7 @@
  #include "windows.hpp"
 --- a/src/raw_encoder.cpp
 +++ b/src/raw_encoder.cpp
-@@ -17,6 +17,11 @@
+@@ -27,6 +27,11 @@
      along with this program.  If not, see <http://www.gnu.org/licenses/>.
  */
  
@@ -30,7 +30,7 @@
  #include "likely.hpp"
 --- a/src/trie.cpp
 +++ b/src/trie.cpp
-@@ -17,11 +17,11 @@
+@@ -27,11 +27,11 @@
      along with this program.  If not, see <http://www.gnu.org/licenses/>.
  */
  
@@ -46,7 +46,7 @@
  #include "windows.hpp"
 --- a/src/encoder.hpp
 +++ b/src/encoder.hpp
-@@ -29,7 +29,6 @@
+@@ -39,7 +39,6 @@
  #include <stddef.h>
  #include <string.h>
  #include <stdlib.h>
@@ -56,7 +56,7 @@
  #include "msg.hpp"
 --- a/src/v1_encoder.cpp
 +++ b/src/v1_encoder.cpp
-@@ -17,6 +17,11 @@
+@@ -27,6 +27,11 @@
      along with this program.  If not, see <http://www.gnu.org/licenses/>.
  */
  
@@ -70,7 +70,7 @@
  #include "likely.hpp"
 --- a/src/v2_encoder.cpp
 +++ b/src/v2_encoder.cpp
-@@ -17,6 +17,11 @@
+@@ -27,6 +27,11 @@
      along with this program.  If not, see <http://www.gnu.org/licenses/>.
  */