kernel/modules: build pcompress.ko for kernel >=2.6.30
authorGabor Juhos <juhosg@openwrt.org>
Sat, 9 May 2009 06:16:56 +0000 (06:16 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 9 May 2009 06:16:56 +0000 (06:16 +0000)
SVN-Revision: 15737

package/kernel/modules/crypto.mk

index 78a8a19fbf174d8c271a12df2fce12d92bf7e54b..68c1a95cfe82a62e880695c55140c30d4986fc6a 100644 (file)
@@ -28,11 +28,14 @@ endif
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.26)),1)
   SHA512_SUFFIX:=$(CRYPTO_GENERIC)
 endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.30)),1)
+  CRYPTO_MODULE_PCOMPRESS:=PCOMPRESS=pcompress
+endif
 
 CRYPTO_MODULES = \
        ALGAPI=crypto_algapi \
        AEAD=aead \
-       $(if $(LINUX_2_6_30),PCOMPRESS=pcompress) \
+       $(CRYPTO_MODULE_PCOMPRESS) \
        BLKCIPHER=$(BLKCIPHER_PREFIX)blkcipher \
        HASH=crypto_hash \
        MANAGER=cryptomgr \