sixproxd: fix compilation with GCC 10 547/head
authorRosen Penev <rosenp@gmail.com>
Sun, 19 Jul 2020 07:03:11 +0000 (00:03 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 19 Jul 2020 21:55:29 +0000 (14:55 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/siproxd/Makefile
net/siproxd/patches/020-gcc10.patch [new file with mode: 0644]

index 68a4b7e7bee37bd7d505d3e1d0c3f8dca2ccfcca..b7a603aecd49fa2bb6bf1c49fdf12f8b5fcb7946 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=siproxd
 PKG_VERSION:=0.8.2
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/siproxd
diff --git a/net/siproxd/patches/020-gcc10.patch b/net/siproxd/patches/020-gcc10.patch
new file mode 100644 (file)
index 0000000..f8be5cd
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/accessctl.c
++++ b/src/accessctl.c
+@@ -34,7 +34,7 @@
+ static char const ident[]="$Id: accessctl.c 521 2015-09-13 08:43:04Z hb9xar $";
+ /* configuration storage */
+-struct siproxd_config configuration;
++extern struct siproxd_config configuration;
+ /*