[packages] ucarp: fix url, add license, cleanup Makefile
authorStephen Walker <stephendwalker@gmail.com>
Sun, 21 Feb 2010 00:06:37 +0000 (00:06 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 21 Feb 2010 00:06:37 +0000 (00:06 +0000)
SVN-Revision: 19787

net/ucarp/Makefile

index 77d63f4a422e7077ffc346e4f555828406d9e487..b02000f59ec89b15448ea373bc45a40379a77bc1 100644 (file)
@@ -1,16 +1,19 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ucarp
 PKG_VERSION:=1.5.1
 PKG_RELEASE:=1
 
-PKG_MD5SUM:=9219ea8214198e8af751353a132087bb
-PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=http://download.pureftpd.org/pub/ucarp
+PKG_MD5SUM:=9219ea8214198e8af751353a132087bb
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,7 +21,7 @@ define Package/ucarp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Lets several hosts share one IP
-  URL:=http://carp.org
+  URL:=http://www.ucarp.org/project/ucarp
 endef
 
 define Package/ucarp/description