fcgi libc++ fix
authorJohn Crispin <john@openwrt.org>
Fri, 3 Aug 2012 21:35:32 +0000 (21:35 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 3 Aug 2012 21:35:32 +0000 (21:35 +0000)
SVN-Revision: 32962

libs/fcgi/Makefile

index f0dc3170a41d5a1c198bd195031afcd3673b6996..f566ec1e78a30df6ed2440a9992f3a17779fef20 100644 (file)
@@ -19,6 +19,7 @@ PKG_FIXUP:=libtool-ucxx
 
 PKG_INSTALL:=1
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/fcgi/Default
@@ -36,7 +37,7 @@ endef
 
 define Package/fcgixx
   $(call Package/fcgi/Default)
-  DEPENDS:=fcgi +uclibcxx
+  DEPENDS:=fcgi $(CXX_DEPENDS)
   TITLE:=Shared library of FastCGI++
 endef
 
@@ -46,7 +47,6 @@ define Package/fcgi/description
  server specific APIs.
 endef
 
-TARGET_CXX=g++-uc
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \