containerd: fix build with golang 1.16
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 24 Feb 2021 18:37:59 +0000 (15:37 -0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 26 Feb 2021 11:47:15 +0000 (12:47 +0100)
Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 2d48a7b6e0a5d73962a7cf4bd32a80c762d2f35b)

utils/containerd/Makefile

index dcf348234478e031dc9e2267a1da1ea3f0f9a099..3ab6499941b1dcf61065da91baf9fd7f05c02b91 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=containerd
 PKG_VERSION:=1.4.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -36,6 +36,7 @@ define Package/containerd/description
 An industry-standard container runtime with an emphasis on simplicity, robustness and portability
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
 GO_PKG_INSTALL_ALL:=1
 MAKE_PATH:=$(GO_PKG_WORK_DIR_NAME)/build/src/$(GO_PKG)
 MAKE_VARS += $(GO_PKG_VARS)