usb: fix musl compatibility 1466/head
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Jun 2015 12:49:05 +0000 (14:49 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Jun 2015 12:49:52 +0000 (14:49 +0200)
Replace the nonstandard `SIGCLD` signal name with the proper `SIGCHLD` spelling
as the `SIGCLD` alias is not provided by musl.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
net/usbip/Makefile
net/usbip/patches-2.0/100-musl-compat.patch [new file with mode: 0644]

index 8aa0df0eb78262bfd3514db8d1058c866a081e53..49130574fa43b0a71ab8b9312f699eafcaf19a25 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=usbip
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_LICENSE:=GPL-2.0
 
 # Since kernel 2.6.39.1 userspace tools are inside the kernel tree
diff --git a/net/usbip/patches-2.0/100-musl-compat.patch b/net/usbip/patches-2.0/100-musl-compat.patch
new file mode 100644 (file)
index 0000000..a64678c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/usbipd.c
++++ b/src/usbipd.c
+@@ -453,7 +453,7 @@ static void set_signal(void)
+       sigaction(SIGTERM, &act, NULL);
+       sigaction(SIGINT, &act, NULL);
+       act.sa_handler = SIG_IGN;
+-      sigaction(SIGCLD, &act, NULL);
++      sigaction(SIGCHLD, &act, NULL);
+ }
+ static const char *pid_file;