[packages] mdadm: update to version 3.2.5
authorLuka Perkov <luka@openwrt.org>
Mon, 16 Jul 2012 21:52:06 +0000 (21:52 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 16 Jul 2012 21:52:06 +0000 (21:52 +0000)
SVN-Revision: 32753

utils/mdadm/Makefile
utils/mdadm/patches/000-compile.patch [new file with mode: 0644]
utils/mdadm/patches/100-cross_compile.patch

index e631e21c16daa2d66d43cbd09a768bad66cc6aca..89615b4158d17d524bae1cf5429a8b42a329c8a8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mdadm
-PKG_VERSION:=3.2.3
+PKG_VERSION:=3.2.5
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=@KERNEL/linux/utils/raid/mdadm
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=7ba1649353b60d8a028af27d9c3ca788
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=2fd33dedcdb06f0d1461f50ddabb7e4a
 
 PKG_BUILD_PARALLEL:=1
 
@@ -24,7 +24,6 @@ define Package/mdadm
   CATEGORY:=Utilities
   TITLE:=A tool for managing Soft RAID under Linux
   URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm/
-  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
 define Package/mdadm/description
diff --git a/utils/mdadm/patches/000-compile.patch b/utils/mdadm/patches/000-compile.patch
new file mode 100644 (file)
index 0000000..6d47489
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/sha1.h
++++ b/sha1.h
+@@ -26,8 +26,6 @@
+ # include <limits.h>
+ #endif
+-#include "ansidecl.h"
+-
+ /* The following contortions are an attempt to use the C preprocessor
+    to determine an unsigned integral type that is 32 bits wide.  An
+    alternative approach is to use autoconf's AC_CHECK_SIZEOF macro, but
index 58612634ca84871018d8fee88ab5825c033a3770..8709e57816baebe9eadbc5ef4fae28bc40076200 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -76,7 +76,6 @@ FAILED_SLOTS_DIR = /dev/.mdadm/failed-sl
+@@ -76,7 +76,6 @@ FAILED_SLOTS_DIR = /run/mdadm/failed-slo
  DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
  DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
  DIRFLAGS += -DFAILED_SLOTS_DIR=\"$(FAILED_SLOTS_DIR)\"
@@ -8,7 +8,7 @@
  
  # The glibc TLS ABI requires applications that call clone(2) to set up
  # TLS data structures, use pthreads until mdmon implements this support
-@@ -184,7 +183,7 @@ test_stripe : restripe.c mdadm.h
+@@ -183,7 +182,7 @@ raid6check : raid6check.o mdadm.h $(CHEC
  
  mdassemble : $(ASSEMBLE_SRCS) $(INCL)
        rm -f $(OBJS)