treewide: move binary of alternatives to libexec, rename as suggested
authorHuangbin Zhan <zhanhb88@gmail.com>
Thu, 8 Oct 2020 12:22:51 +0000 (20:22 +0800)
committerHuangbin Zhan <zhanhb88@gmail.com>
Thu, 8 Oct 2020 12:22:51 +0000 (20:22 +0800)
Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
devel/diffutils/Makefile
net/bridge-utils/Makefile
net/openssh/Makefile
net/wget/Makefile
utils/findutils/Makefile

index 65a41f8ebb775c0ffe61b20ab347714e3dab42de..ec889771057d272c3fb9298ac696156bdeb2b827 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=diffutils
 PKG_VERSION:=3.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/diffutils
@@ -31,9 +31,8 @@ define Package/diffutils
   TITLE:=diffutils
   URL:=http://www.gnu.org/software/diffutils/
   ALTERNATIVES:=\
-    200:/usr/bin/cmp:/usr/bin/gnu-cmp \
-    200:/usr/bin/diff:/usr/bin/gnu-diff \
-
+    200:/usr/bin/cmp:/usr/libexec/cmp-gnu \
+    200:/usr/bin/diff:/usr/libexec/diff-gnu
 endef
 
 define Package/diffutils/description
@@ -48,8 +47,9 @@ CONFIGURE_VARS += \
 define Package/diffutils/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{sdiff,diff3} $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/diff $(1)/usr/bin/gnu-diff
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cmp $(1)/usr/bin/gnu-cmp
+       $(INSTALL_DIR) $(1)/usr/libexec
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/diff $(1)/usr/libexec/diff-gnu
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cmp $(1)/usr/libexec/cmp-gnu
 endef
 
 $(eval $(call BuildPackage,diffutils))
index b5511cd41c8f1c0c833a31fbfd5c732cfeb6f00c..dc837c9bbd06afe1973518930e0e98828e4a9806 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
 PKG_VERSION:=1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/shemminger/bridge-utils
@@ -31,7 +31,7 @@ define Package/bridge
   CATEGORY:=Base system
   TITLE:=Ethernet bridging configuration utility
   URL:=http://www.linuxfromscratch.org/blfs/view/svn/basicnet/bridge-utils.html
-  ALTERNATIVES:=300:/usr/sbin/brctl:/usr/libexec/bridge-utils-brctl
+  ALTERNATIVES:=300:/usr/sbin/brctl:/usr/libexec/brctl-bridge-utils
 endef
 
 define Package/bridge/description
@@ -44,7 +44,7 @@ CONFIGURE_ARGS += \
 
 define Package/bridge/install
        $(INSTALL_DIR) $(1)/usr/libexec
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/brctl $(1)/usr/libexec/bridge-utils-brctl
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/brctl $(1)/usr/libexec/brctl-bridge-utils
 endef
 
 $(eval $(call BuildPackage,bridge))
index c93ae279434e5c71dc939e54c30b6f2812c6dedc..1782b02f667cb1db662148e19e0a7f831ccbbc5a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=8.4p1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
@@ -49,9 +49,8 @@ define Package/openssh-client
        $(call Package/openssh/Default)
        TITLE+= client
        ALTERNATIVES:=\
-               200:/usr/bin/ssh:/usr/bin/openssh-ssh \
-               200:/usr/bin/scp:/usr/bin/openssh-scp \
-
+               200:/usr/bin/ssh:/usr/libexec/ssh-openssh \
+               200:/usr/bin/scp:/usr/libexec/scp-openssh
 endef
 
 define Package/openssh-client/description
@@ -197,9 +196,9 @@ define Package/openssh-client/install
        $(INSTALL_DIR) $(1)/etc/ssh
        chmod 0700 $(1)/etc/ssh
        $(CP) $(PKG_INSTALL_DIR)/etc/ssh/ssh_config $(1)/etc/ssh/
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh $(1)/usr/bin/openssh-ssh
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scp $(1)/usr/bin/openssh-scp
+       $(INSTALL_DIR) $(1)/usr/libexec
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ssh $(1)/usr/libexec/ssh-openssh
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scp $(1)/usr/libexec/scp-openssh
 endef
 
 define Package/openssh-client-utils/install
index ffad46109d01ab398540303752ae2862ce104b05..fd1a2164ba570ff6b40e7dbaf8b8c0dd0bfebdfe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wget
 PKG_VERSION:=1.20.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -47,7 +47,7 @@ $(call Package/wget/Default)
   TITLE+= (with SSL support)
   VARIANT:=ssl
   PROVIDES+=wget-ssl
-  ALTERNATIVES:=300:/usr/bin/wget:/usr/bin/wget-ssl
+  ALTERNATIVES:=300:/usr/bin/wget:/usr/libexec/wget-ssl
 endef
 
 define Package/wget/description
@@ -60,7 +60,7 @@ $(call Package/wget/Default)
   TITLE+= (without SSL support)
   VARIANT:=nossl
   PROVIDES+=wget
-  ALTERNATIVES:=300:/usr/bin/wget:/usr/bin/wget-nossl
+  ALTERNATIVES:=300:/usr/bin/wget:/usr/libexec/wget-nossl
 endef
 
 define Package/wget-nossl/description
@@ -95,13 +95,13 @@ ifeq ($(BUILD_VARIANT),nossl)
 endif
 
 define Package/wget/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/wget $(1)/usr/bin/wget-ssl
+       $(INSTALL_DIR) $(1)/usr/libexec
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/wget $(1)/usr/libexec/wget-ssl
 endef
 
 define Package/wget-nossl/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/wget $(1)/usr/bin/wget-nossl
+       $(INSTALL_DIR) $(1)/usr/libexec
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/wget $(1)/usr/libexec/wget-nossl
 endef
 
 $(eval $(call BuildPackage,wget))
index 25c46ce27997e5bcb0635241fe54c9c5f8d26750..0a5821d90f29065e02d11d30cc77610a1907345b 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=findutils
 PKG_VERSION:=4.7.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -49,13 +49,13 @@ endef
 define Package/findutils-find
        $(call Package/findutils/Default)
        TITLE+= - find utility
-       ALTERNATIVES:=300:/usr/bin/find:/usr/libexec/findutils-find
+       ALTERNATIVES:=300:/usr/bin/find:/usr/libexec/find-findutils
 endef
 
 define Package/findutils-xargs
        $(call Package/findutils/Default)
        TITLE+= - xargs utility
-       ALTERNATIVES:=300:/usr/bin/xargs:/usr/libexec/findutils-xargs
+       ALTERNATIVES:=300:/usr/bin/xargs:/usr/libexec/xargs-findutils
 endef
 
 define Package/findutils-locate
@@ -74,12 +74,12 @@ endef
 
 define Package/findutils-find/install
        $(INSTALL_DIR) $(1)/usr/libexec
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/find $(1)/usr/libexec/findutils-find
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/find $(1)/usr/libexec/find-findutils
 endef
 
 define Package/findutils-xargs/install
        $(INSTALL_DIR) $(1)/usr/libexec
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xargs $(1)/usr/libexec/findutils-xargs
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xargs $(1)/usr/libexec/xargs-findutils
 endef
 
 define Package/findutils-locate/install