Merge pull request #1722 from rraptorr/bind-ecdsa
authorNoah Meyerhans <frodo@morgul.net>
Fri, 4 Sep 2015 18:24:34 +0000 (11:24 -0700)
committerNoah Meyerhans <frodo@morgul.net>
Fri, 4 Sep 2015 18:24:34 +0000 (11:24 -0700)
bind: Enable ECDSA support

net/bind/Makefile

index dca601c15b9606acc23d757862835ba46d63f2c5..be4fc836c0624aa8f6824d9ef4ee76cf35af5a6d 100644 (file)
@@ -27,6 +27,8 @@ PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
 
 PKG_INSTALL:=1
 
+PKG_CONFIG_DEPENDS := CONFIG_OPENSSL_WITH_EC
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bind/Default
@@ -100,7 +102,7 @@ CONFIGURE_ARGS += \
        --enable-epoll=yes \
        --with-gost=no \
        --with-gssapi=no \
-       --with-ecdsa=no \
+       --with-ecdsa=$(if $(CONFIG_OPENSSL_WITH_EC),yes,no) \
        --with-readline=no
 
 CONFIGURE_VARS += \