coreutils: Add alternatives support for runcon
authorHuangbin Zhan <zhanhb88@gmail.com>
Tue, 27 Oct 2020 18:39:53 +0000 (02:39 +0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 28 Oct 2020 03:51:12 +0000 (20:51 -0700)
Avoid conflict with package busybox-selinux

Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
utils/coreutils/Makefile

index 66805d9024ed8f49eda0c922ee142a661dbe7708..62cb51fadfc67b6db444d52e3a3cbed08e9a0310 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coreutils
 PKG_VERSION:=8.32
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/coreutils
@@ -44,9 +44,9 @@ DIR_BIN := \
 DIR_USR_BIN := \
        basename chcon cksum comm cut dirname du env expand expr factor fold    \
        groups head hostid id install logname md5sum mkfifo nl nohup nproc od   \
-       paste printf readlink realpath seq sha1sum sha256sum sha512sum shred    \
-       shuf sort split sum tac tail tee test timeout tr truncate tty unexpand  \
-       uniq unlink uptime users wc who whoami yes
+       paste printf readlink realpath runcon seq sha1sum sha256sum sha512sum   \
+       shred shuf sort split sum tac tail tee test timeout tr truncate tty     \
+       unexpand uniq unlink uptime users wc who whoami yes
 
 DIR_USR_SBIN := \
        chroot
@@ -54,7 +54,7 @@ DIR_USR_SBIN := \
 # BusyBox does not provide these yet
 DIR_OTHERS := \
        base32 b2sum basenc csplit dir dircolors fmt join numfmt pathchk pinky  \
-       pr ptx runcon sha224sum sha384sum stdbuf tsort vdir
+       pr ptx sha224sum sha384sum stdbuf tsort vdir
 
 $(eval $(foreach a,$(DIR_BIN),ALTS_$(a):=300:/bin/$(a):/usr/bin/gnu-$(a)$(newline)))
 $(eval $(foreach a,$(DIR_USR_BIN),ALTS_$(a):=300:/usr/bin/$(a):/usr/bin/gnu-$(a)$(newline)))