Merge pull request #13573 from ja-pa/ooniprobe-3.0.7
authorRosen Penev <rosenp@gmail.com>
Tue, 6 Oct 2020 10:17:02 +0000 (03:17 -0700)
committerGitHub <noreply@github.com>
Tue, 6 Oct 2020 10:17:02 +0000 (03:17 -0700)
ooniprobe: update to version 3.0.7

lang/python/python3-pyroute2/Makefile
net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/update_no-ip_com.sh
net/ddns-scripts/files/usr/share/ddns/default/no-ip.com.json
net/dnstap/Makefile
net/netifyd/Makefile

index 4e08314d3886ad42d230dde4a1c519a8bb0fefa0..9383069f19b7911a083ec9d66e7c9aa2f2aa66b5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+# Copyright (C) 2019-2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python3-pyroute2
-PKG_VERSION:=0.5.7
-PKG_RELEASE:=2
+PKG_VERSION:=0.5.14
+PKG_RELEASE:=1
 
 PYPI_NAME:=pyroute2
-PKG_HASH:=963fce07da2841456d39e3b932b071f6de28d23dadfae014022d67a752916f98
+PKG_HASH:=774c5ecf05fe40f0f601a7ab33c19ca0b24f00bf4a094e58deaa5333b7ca49b5
 
 PKG_MAINTAINER:=Martin MatÄ›jek <martin.matejek@nic.cz>
 PKG_LICENSE:=GPL-2.0-or-later Apache-2.0
index e9987b056ebcdf9e573c537b1fa9da8e812e7ad1..912e6d8609415ec7ff6a81d328ed1d73fc87d266 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
-PKG_VERSION:=2.8.1
+PKG_VERSION:=2.8.2
 PKG_RELEASE:=1
 
 PKG_LICENSE:=GPL-2.0
index 7d4354bd6d2b794d177001b038d950041730346b..e13058b14cd694eb627007bcf2eb3410f569c9cc 100644 (file)
 # so we send a dummy (localhost) and a seconds later we send the correct IP addr
 #
 local __DUMMY
-local __UPDURL="http://[USERNAME]:[PASSWORD]@dynupdate.no-ip.com/nic/update?hostname=[DOMAIN]&myip=[IP]"
+local __UPDURL6="http://[USERNAME]:[PASSWORD]@dynupdate6.noip.com/nic/update?hostname=[DOMAIN]&myip=[IP]"
+local __UPDURL="http://[USERNAME]:[PASSWORD]@dynupdate.noip.com/nic/update?hostname=[DOMAIN]&myip=[IP]"
 # inside url we need username and password
 [ -z "$username" ] && write_log 14 "Service section not configured correctly! Missing 'username'"
 [ -z "$password" ] && write_log 14 "Service section not configured correctly! Missing 'password'"
 
 # set IP version dependend dummy (localhost)
 [ $use_ipv6 -eq 0 ] && __DUMMY="127.0.0.1" || __DUMMY="::1"
+[ $use_ipv6 -eq 0 ] && __UPDURL=$__UPDURL || __UPDURL=$__UPDURL6
 
 # lets do DUMMY transfer
 write_log 7 "sending dummy IP to 'no-ip.com'"
index 3cf6f92487ab233bc3c47256ce08766507391ac0..e0f8ccb543c558e7b7f47338845daf232964c710 100644 (file)
@@ -2,6 +2,9 @@
        "name": "no-ip.com",
        "ipv4": {
                "url": "update_no-ip_com.sh"
+       },
+       "ipv6": {
+               "url": "update_no-ip_com.sh"
        }
 }
 
index ccb8ad741cbb1e5bb9644537396917c595aa3333..d2dc7e10c710c4712db74e309f014063b3001d31 100644 (file)
@@ -8,19 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnstap
-PKG_VERSION:=0.2.1
+PKG_VERSION:=0.2.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=golang-dnstap-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/dnstap/golang-dnstap/archive/v$(PKG_VERSION)/
-PKG_HASH:=2b0b7bf32ceb2cdbc4d3956a7bd437ef332c615443a4dee808d9c1129ffd7f30
+PKG_HASH:=c7eb42f1f0ca7247b22b774dd78d9874b9db776fa9072f92a5f3a945000b7a60
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/golang-dnstap-$(PKG_VERSION)
-PKG_BUILD_DEPENDS:=golang/host 
+PKG_BUILD_DEPENDS:=golang/host
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
 
@@ -32,7 +32,7 @@ include ../../lang/golang/golang-package.mk
 define Package/dnstap
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=dnstap command-line tool 
+  TITLE:=dnstap command-line tool
   URL:=https://dnstap.info
   DEPENDS:=$(GO_ARCH_DEPENDS)
 endef
index 538aa16ad96283501eb22daf89ca9e3c1c4a1863..b8d3aad0d390930945558437e31332cce89bdc19 100644 (file)
@@ -16,10 +16,10 @@ PKG_INSTALL:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://gitlab.com/netify.ai/public/netify-agent.git
-PKG_SOURCE_DATE:=2020-04-29
-PKG_SOURCE_VERSION:=v3.00
-#PKG_SOURCE_VERSION:=6f739939e19d8713edc99c2c601df3d5ba7a0d2e
-PKG_MIRROR_HASH:=c9a3da698e5014eeff8e6b4089d09c2a98a2e2e4dce15b7d4e3df6dd0379fcb4
+PKG_SOURCE_DATE:=2020-09-15
+PKG_SOURCE_VERSION:=v3.05
+#PKG_SOURCE_VERSION:=09fa5fb202ba95ee2d73a4eb0fefe9265d15c780
+PKG_MIRROR_HASH:=2bcaa54f1660a30070f0c79a79259e96f169a9c7a0fe4a1195bb74f7de184204
 
 include $(INCLUDE_DIR)/package.mk