added the wshaper script
authorMatteo Croce <rootkit85@yahoo.it>
Sat, 8 Mar 2008 13:15:24 +0000 (13:15 +0000)
committerMatteo Croce <rootkit85@yahoo.it>
Sat, 8 Mar 2008 13:15:24 +0000 (13:15 +0000)
SVN-Revision: 10569

net/wshaper/Makefile [new file with mode: 0644]
net/wshaper/files/wshaper.htb [new file with mode: 0755]

diff --git a/net/wshaper/Makefile b/net/wshaper/Makefile
new file mode 100644 (file)
index 0000000..691d263
--- /dev/null
@@ -0,0 +1,48 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wshaper
+PKG_VERSION:=0.1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wshaper
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+kmod-sched +tc
+  TITLE:=wshaper
+  URL:=http://lartc.org/wondershaper/
+endef
+
+define Package/wshaper/description
+ A script to do traffing shaping with the HTB algorithm.
+ Wshaper attempts to:
+ * Maintain low latency for interfactive traffic at all times 
+ * Allow 'surfing' at reasonable speeds while up or downloading
+ * Make sure uploads don't harm downloads, and the other way around
+endef
+
+define Build/Prepare
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/wshaper/install
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/wshaper.htb $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,wshaper))
diff --git a/net/wshaper/files/wshaper.htb b/net/wshaper/files/wshaper.htb
new file mode 100755 (executable)
index 0000000..2600d43
--- /dev/null
@@ -0,0 +1,132 @@
+#!/bin/sh
+# Wonder Shaper
+# please read the README before filling out these values 
+#
+# Set the following values to somewhat less than your actual download
+# and uplink speed. In kilobits. Also set the device that is to be shaped.
+
+DOWNLINK=2000
+UPLINK=240
+DEV=eth0
+
+# low priority OUTGOING traffic - you can leave this blank if you want
+# low priority source netmasks
+NOPRIOHOSTSRC=
+
+# low priority destination netmasks
+NOPRIOHOSTDST=
+
+# low priority source ports
+NOPRIOPORTSRC=
+
+# low priority destination ports
+NOPRIOPORTDST="21"
+
+if [ "$1" = "status" ]
+then
+       tc -s qdisc ls dev $DEV
+       tc -s class ls dev $DEV
+       exit
+fi
+
+# clean existing down- and uplink qdiscs, hide errors
+tc qdisc del dev $DEV root    2> /dev/null > /dev/null
+tc qdisc del dev $DEV ingress 2> /dev/null > /dev/null
+
+###### uplink
+
+# install root HTB, point default traffic to 1:20:
+
+tc qdisc add dev $DEV root handle 1: htb default 20
+
+# shape everything at $UPLINK speed - this prevents huge queues in your
+# DSL modem which destroy latency:
+
+tc class add dev $DEV parent 1: classid 1:1 htb rate ${UPLINK}kbit burst 6k
+
+# high prio class 1:10:
+
+tc class add dev $DEV parent 1:1 classid 1:10 htb rate ${UPLINK}kbit \
+   burst 6k prio 1
+
+# bulk & default class 1:20 - gets slightly less traffic, 
+# and a lower priority:
+
+tc class add dev $DEV parent 1:1 classid 1:20 htb rate $((9*$UPLINK/10))kbit \
+   burst 6k prio 2
+
+tc class add dev $DEV parent 1:1 classid 1:30 htb rate $((8*$UPLINK/10))kbit \
+   burst 6k prio 2
+
+# all get Stochastic Fairness:
+tc qdisc add dev $DEV parent 1:10 handle 10: sfq perturb 10
+tc qdisc add dev $DEV parent 1:20 handle 20: sfq perturb 10
+tc qdisc add dev $DEV parent 1:30 handle 30: sfq perturb 10
+
+# TOS Minimum Delay (ssh, NOT scp) in 1:10:
+
+tc filter add dev $DEV parent 1:0 protocol ip prio 10 u32 \
+      match ip tos 0x10 0xff  flowid 1:10
+
+# ICMP (ip protocol 1) in the interactive class 1:10 so we 
+# can do measurements & impress our friends:
+tc filter add dev $DEV parent 1:0 protocol ip prio 10 u32 \
+        match ip protocol 1 0xff flowid 1:10
+
+# To speed up downloads while an upload is going on, put ACK packets in
+# the interactive class:
+
+tc filter add dev $DEV parent 1: protocol ip prio 10 u32 \
+   match ip protocol 6 0xff \
+   match u8 0x05 0x0f at 0 \
+   match u16 0x0000 0xffc0 at 2 \
+   match u8 0x10 0xff at 33 \
+   flowid 1:10
+
+# rest is 'non-interactive' ie 'bulk' and ends up in 1:20
+
+# some traffic however suffers a worse fate
+for a in $NOPRIOPORTDST
+do
+       tc filter add dev $DEV parent 1: protocol ip prio 14 u32 \
+          match ip dport $a 0xffff flowid 1:30
+done
+
+for a in $NOPRIOPORTSRC
+do
+       tc filter add dev $DEV parent 1: protocol ip prio 15 u32 \
+          match ip sport $a 0xffff flowid 1:30
+done
+
+for a in $NOPRIOHOSTSRC
+do
+       tc filter add dev $DEV parent 1: protocol ip prio 16 u32 \
+          match ip src $a flowid 1:30
+done
+
+for a in $NOPRIOHOSTDST
+do
+       tc filter add dev $DEV parent 1: protocol ip prio 17 u32 \
+          match ip dst $a flowid 1:30
+done
+
+# rest is 'non-interactive' ie 'bulk' and ends up in 1:20
+
+tc filter add dev $DEV parent 1: protocol ip prio 18 u32 \
+   match ip dst 0.0.0.0/0 flowid 1:20
+
+
+########## downlink #############
+# slow downloads down to somewhat less than the real speed  to prevent 
+# queuing at our ISP. Tune to see how high you can set it.
+# ISPs tend to have *huge* queues to make sure big downloads are fast
+#
+# attach ingress policer:
+
+tc qdisc add dev $DEV handle ffff: ingress
+
+# filter *everything* to it (0.0.0.0/0), drop everything that's
+# coming in too fast:
+
+tc filter add dev $DEV parent ffff: protocol ip prio 50 u32 match ip src \
+   0.0.0.0/0 police rate ${DOWNLINK}kbit burst 10k drop flowid :1