Document: add PLAT_PARTITION_MAX_ENTRIES define
authorHaojian Zhuang <haojian.zhuang@linaro.org>
Wed, 17 Aug 2016 13:05:07 +0000 (21:05 +0800)
committerHaojian Zhuang <haojian.zhuang@linaro.org>
Tue, 20 Sep 2016 05:21:11 +0000 (13:21 +0800)
Partition driver requires the "PLAT_PARTITION_MAX_ENTRIES" definition.

By default, it's defined to 128 in partition driver. But it costs a lot
of memory, and only a few partition entries are really used in platform
partition table. If user wants use memory efficiently, user should
define the build flag in platform.mk instead.

Signed-off-by: Haojian Zhuang <haojian.zhuang@linaro.org>
docs/porting-guide.md

index 8dad4a0516ce902dabddf4f095966c165fc10ddf..aa1ff45ef6968d2432bbac241827d10932d07a95 100644 (file)
@@ -501,6 +501,17 @@ optionally be defined:
     PLAT_PL061_MAX_GPIOS    :=      160
     $(eval $(call add_define,PLAT_PL061_MAX_GPIOS))
 
+If the platform port uses the partition driver, the following constant may
+optionally be defined:
+
+*   **PLAT_PARTITION_MAX_ENTRIES**
+    Maximum number of partition entries required by the platform. This allows
+    control how much memory is allocated for partition entries. The default
+    value is 128.
+    [For example, define the build flag in platform.mk]:
+    PLAT_PARTITION_MAX_ENTRIES :=      12
+    $(eval $(call add_define,PLAT_PARTITION_MAX_ENTRIES))
+
 
 ### File : plat_macros.S [mandatory]