dockerd: fix build with golang 1.16
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 24 Feb 2021 18:37:59 +0000 (15:37 -0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 26 Feb 2021 11:48:48 +0000 (12:48 +0100)
Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be
built in non-module mode.

Module-aware mode will be mandatory in the next golang release.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 8a4bb56478036efccbf6f092647da53e52574518)

utils/dockerd/Makefile

index c34640a855c4d81b3ae5622cd4334760c94ea8bf..1390ae0980c930597e2ca287ced43c736c273213 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dockerd
 PKG_VERSION:=20.10.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -46,6 +46,7 @@ define Package/dockerd/description
 The Docker CE Engine.
 endef
 
+GO_PKG_BUILD_VARS += GO111MODULE=auto
 TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
 TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)