loudmouth: Disable debug and fix no deprecated API compilation 7531/head
authorRosen Penev <rosenp@gmail.com>
Tue, 27 Nov 2018 17:41:55 +0000 (09:41 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 27 Nov 2018 18:04:46 +0000 (10:04 -0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/loudmouth/Makefile
libs/loudmouth/patches/020-openssl-deprecated.patch [new file with mode: 0644]

index 93d3bd448f2a35de1c6fa8d31603a01a9a505cc3..9216d7b6bc410d628ce1bc19c92333e51a012004 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=loudmouth
 PKG_VERSION:=1.5.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/mcabber/loudmouth/tar.gz/$(PKG_VERSION)?
@@ -38,10 +38,15 @@ define Package/loudmouth/description
 endef
 
 CONFIGURE_ARGS += \
+       --disable-debug \
        --without-compile-warnings \
        --without-idn \
        --with-ssl=openssl
 
+CONFIGURE_VARS += \
+       ac_cv_lib_crypto_BIO_f_base64=yes \
+       ac_cv_lib_ssl_SSL_new=yes
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(CP) \
diff --git a/libs/loudmouth/patches/020-openssl-deprecated.patch b/libs/loudmouth/patches/020-openssl-deprecated.patch
new file mode 100644 (file)
index 0000000..976d9b9
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/loudmouth/lm-ssl-openssl.c
++++ b/loudmouth/lm-ssl-openssl.c
+@@ -345,9 +345,11 @@ _lm_ssl_initialize (LmSSL *ssl)
+     /*const char *cert_file = NULL;*/
+     if (!initialized) {
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+         SSL_library_init();
+         /* FIXME: Is this needed when we are not in debug? */
+         SSL_load_error_strings();
++#endif
+         initialized = TRUE;
+     }