[packages] ipset: fix kernel architecture (#11345)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Apr 2012 14:36:02 +0000 (14:36 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Apr 2012 14:36:02 +0000 (14:36 +0000)
The buildsystem passes ARCH="$(ARCH)" by default, but when building kernel modules
we need to pass ARCH="$(LINUX_KARCH)" since Linux uses differet arch names in Kbuild.
Fixes ipset build on brcm47xx (mipsel -> mips) and likely others.

SVN-Revision: 31468

net/ipset/Makefile

index c214be673f996c8961cb48881c4fbb79a50b5724..ea6e9d87e5ed283df0509a82e7ee80d8aa0bc8d3 100644 (file)
@@ -34,11 +34,12 @@ $(call Package/ipset/Default)
   URL:=http://ipset.netfilter.org/
 endef
 
-include $(INCLUDE_DIR)/kernel-defaults.mk
-
 CONFIGURE_ARGS += \
        --with-kbuild="$(LINUX_DIR)"
 
+MAKE_FLAGS += \
+       ARCH="$(LINUX_KARCH)"
+
 IPSET_MODULES:= \
        ipset/ip_set \
        ipset/ip_set_bitmap_ip \