[package] enable readline support in bc
authorFlorian Fainelli <florian@openwrt.org>
Sat, 26 Feb 2011 14:51:03 +0000 (14:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 26 Feb 2011 14:51:03 +0000 (14:51 +0000)
Signed-off-by: Xiangfu Liu <xiangfu.z@gmail.com>
SVN-Revision: 25728

utils/bc/Makefile

index f43ff6a32e28e965b31d07284270ee035feb6a6a..23e5b1cccc7977d238d03c1fc1be8b85d9a89fc2 100644 (file)
@@ -26,6 +26,7 @@ endef
 define Package/bc
   $(call Package/bc/Default)
   TITLE:=Arbitrary precision calculator language
+  DEPENDS:=+libreadline
 endef
 
 define Package/bc/description
@@ -44,6 +45,8 @@ define Package/dc/description
  precision arithmetic.
 endef
 
+CONFIGURE_ARGS += --with-readline
+
 define Package/bc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bc/bc $(1)/usr/bin/