valgrind: fix installation on x86
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:56:32 +0000 (21:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:56:32 +0000 (21:56 +0000)
SVN-Revision: 32546

utils/valgrind/Makefile

index 128a5c9af8f6d73374ad102e3770761a3c7bb930..68af36c52632e498d204696efe1ac35911f05862 100644 (file)
@@ -78,6 +78,8 @@ define Package/valgrind/description
        to speed up and reduce memory use of your programs.
 endef
 
+CPU := $(patsubst x86,i386,$(LINUX_KARCH))
+
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
@@ -99,7 +101,7 @@ define Package/valgrind/install
                ./files/default.supp \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(LINUX_KARCH)-*.xml \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-core*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-linux*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \