libextractor: update to 1.13
authorkrant <aleksey.vasilenko@gmail.com>
Sat, 10 Feb 2024 07:35:54 +0000 (09:35 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 10 Feb 2024 12:43:06 +0000 (12:43 +0000)
- Remove obsolete configure option
- Remove patch and var override since MEM_SRCDST_SUPPORTED is always on

Signed-off-by: krant <aleksey.vasilenko@gmail.com>
libs/libextractor/Makefile
libs/libextractor/patches/020-jpeg.patch [deleted file]

index df85a4f8b7d8017ffce2672690f533c74dc350ee..c298c0d1ae8cf32468602f402f08315edcb279cb 100644 (file)
@@ -6,15 +6,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libextractor
-PKG_VERSION:=1.11
-PKG_RELEASE:=3
+PKG_VERSION:=1.13
+PKG_RELEASE:=1
 
 # ToDo:
 # - package missing optional dependencies: libexiv2, gsf, librpm, smf, tidy
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=16f633ab8746a38547c4a1da3f4591192b0825ad83c4336f0575b85843d8bd8f
+PKG_HASH:=bb8f312c51d202572243f113c6b62d8210301ab30cbaee604f9837d878cdf755
 
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
@@ -57,15 +57,11 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
 CONFIGURE_ARGS += \
-       --disable-ffmpeg \
        --disable-glibtest \
        --disable-gsf \
        --disable-rpath \
        --with$(if $(CONFIG_PACKAGE_libextractor-plugin-gstreamer),,out)-gstreamer
 
-CONFIGURE_VARS += \
-       ac_cv_lib_jpeg_jpeg_mem_src=yes
-
 define Package/libextractor
        SECTION:=libs
        CATEGORY:=Libraries
diff --git a/libs/libextractor/patches/020-jpeg.patch b/libs/libextractor/patches/020-jpeg.patch
deleted file mode 100644 (file)
index 3cb8904..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
---- a/src/plugins/jpeg_extractor.c
-+++ b/src/plugins/jpeg_extractor.c
-@@ -31,8 +31,97 @@ typedef int boolean;
- #define HAVE_BOOLEAN
- #endif
- #include <jpeglib.h>
-+#include <jerror.h>
- #include <setjmp.h>
-+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
-+typedef struct {
-+  struct jpeg_source_mgr pub; /* public fields */
-+
-+  JOCTET eoi_buffer[2]; /* a place to put a dummy EOI */
-+} my_source_mgr;
-+
-+typedef my_source_mgr * my_src_ptr;
-+
-+static void
-+init_source (j_decompress_ptr cinfo)
-+{
-+  /* No work, since jpeg_mem_src set up the buffer pointer and count.
-+   * Indeed, if we want to read multiple JPEG images from one buffer,
-+   * this *must* not do anything to the pointer.
-+  */
-+}
-+
-+static boolean
-+fill_input_buffer (j_decompress_ptr cinfo)
-+{
-+  my_src_ptr src = (my_src_ptr) cinfo->src;
-+
-+  WARNMS(cinfo, JWRN_JPEG_EOF);
-+
-+  /* Create a fake EOI marker */
-+  src->eoi_buffer[0] = (JOCTET) 0xFF;
-+  src->eoi_buffer[1] = (JOCTET) JPEG_EOI;
-+  src->pub.next_input_byte = src->eoi_buffer;
-+  src->pub.bytes_in_buffer = 2;
-+
-+  return TRUE;
-+}
-+
-+static void
-+skip_input_data (j_decompress_ptr cinfo, long num_bytes)
-+{
-+  my_src_ptr src = (my_src_ptr) cinfo->src;
-+
-+  if (num_bytes > 0) {
-+    while (num_bytes > (long) src->pub.bytes_in_buffer) {
-+      num_bytes -= (long) src->pub.bytes_in_buffer;
-+      (void) fill_input_buffer(cinfo);
-+      /* note we assume that fill_input_buffer will never
-+       * return FALSE, so suspension need not be handled.
-+       */
-+    }
-+    src->pub.next_input_byte += (size_t) num_bytes;
-+    src->pub.bytes_in_buffer -= (size_t) num_bytes;
-+  }
-+}
-+
-+static void
-+term_source (j_decompress_ptr cinfo)
-+{
-+  /* no work necessary here */
-+}
-+
-+static void
-+jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
-+        unsigned long bufsize)
-+{
-+  my_src_ptr src;
-+
-+  /* The source object is made permanent so that a series of JPEG images
-+   * can be read from a single buffer by calling jpeg_mem_src
-+   * only before the first one.
-+   * This makes it unsafe to use this manager and a different source
-+   * manager serially with the same JPEG object. Caveat programmer.
-+  */
-+  if (cinfo->src == NULL) { /* first time for this JPEG object? */
-+    cinfo->src = (struct jpeg_source_mgr *)
-+      (*cinfo->mem->alloc_small) ((j_common_ptr) cinfo,
-+                                  JPOOL_PERMANENT,
-+                                  sizeof(my_source_mgr));
-+  }
-+
-+  src = (my_src_ptr) cinfo->src;
-+  src->pub.init_source = init_source;
-+  src->pub.fill_input_buffer = fill_input_buffer;
-+  src->pub.skip_input_data = skip_input_data;
-+  src->pub.resync_to_restart = jpeg_resync_to_restart; /* use default method */
-+  src->pub.term_source = term_source;
-+
-+  src->pub.next_input_byte = buffer;
-+  src->pub.bytes_in_buffer = bufsize;
-+}
-+#endif
- /**
-  * Context for custom functions.