freeswitch-stable: bump to 1.8.7 434/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 7 Jul 2019 16:07:50 +0000 (18:07 +0200)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 7 Jul 2019 16:07:52 +0000 (18:07 +0200)
Version bump. Patches refreshed. Upstreamed patches removed.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/freeswitch-stable/Makefile
net/freeswitch-stable/patches/030-fix-configure-ac.patch
net/freeswitch-stable/patches/370-procd-compat.patch
net/freeswitch-stable/patches/400-switch_core_media-fix-stringop-truncation.patch [deleted file]
net/freeswitch-stable/patches/410-mod_say_ja-fix-format-overflow.patch [deleted file]
net/freeswitch-stable/patches/420-mod_kazoo-correct-ei_init-check.patch [deleted file]

index 45d33d44f4d181bb4eceafdea08c0e9d811c4136..958893f96e32991f041485baa484cc3741ee10de 100644 (file)
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PRG_NAME:=freeswitch
 PKG_NAME:=$(PRG_NAME)-stable
-PKG_VERSION:=1.8.6
+PKG_VERSION:=1.8.7
 PKG_RELEASE:=1
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 
 PKG_SOURCE:=$(PRG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://files.$(PRG_NAME).org/releases/$(PRG_NAME)
-PKG_HASH:=b87f47e57d13de2b901bd1e4eb85491178e59a159a2831d7430abe7947f0d3a4
+PKG_HASH:=7d3cee32713db5f65e3d4703c6420038872d8f6efab8be4d58fbf66ffa993008
 
 PKG_CPE_ID:=cpe:/a:freeswitch:freeswitch
 
index 754a0a206af4d4ace688edf9417c480bf4a15d4b..a05ed6a1b72295de894aa21415a39d42664fed84 100644 (file)
@@ -40,7 +40,7 @@
    AC_PATH_PROG([PKG_CONFIG], [pkg-config], [no])
      if test "$PKG_CONFIG" = "no" \
         || test x"$enable_core_pgsql_pkgconfig" = x"no" \
-@@ -1613,13 +1589,7 @@ AC_CHECK_PROG(PERL,perl,[ac_cv_have_perl
+@@ -1614,13 +1590,7 @@ AC_CHECK_PROG(PERL,perl,[ac_cv_have_perl
  # -a "x$ac_cv_have_EXTERN_h" != "xno"
  
  if test "x$ac_cv_have_perl" != "xno"; then
@@ -55,7 +55,7 @@
  
     save_CFLAGS="$CFLAGS"
     CFLAGS="$PERL_CFLAGS"
-@@ -1714,24 +1684,12 @@ then
+@@ -1715,24 +1685,12 @@ then
                if test "$python_has_distutils" != "no" ; then
                        AC_MSG_CHECKING([location of site-packages])
  
index 0549a037338ffd179b04da933c6f74220c1a15db..5bab0f2139cacfdbe754a07f566758681e67832c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/switch_console.c
 +++ b/src/switch_console.c
-@@ -1053,10 +1053,12 @@ static void *SWITCH_THREAD_FUNC console_
+@@ -1051,10 +1051,12 @@ static void *SWITCH_THREAD_FUNC console_
        while (running) {
                int32_t arg = 0;
  
diff --git a/net/freeswitch-stable/patches/400-switch_core_media-fix-stringop-truncation.patch b/net/freeswitch-stable/patches/400-switch_core_media-fix-stringop-truncation.patch
deleted file mode 100644 (file)
index 607df68..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-commit e114c6382e68824d4498f62562714860d20804e2
-Author: Sebastian Kemper <sebastian_ml@gmx.net>
-Date:   Sun Apr 14 19:11:58 2019 +0200
-
-    FS-11783: [core] quiet gcc truncation warning
-    
-    With -Wstringop-truncation gcc warns about calls to bounded string
-    manipulation function "strncpy" that may either truncate the copied
-    string or leave the destination unchanged. To avoid the warning when the
-    result is not expected to be NUL-terminated, it is suggested to call
-    "memcpy" instead.
-    
-    src/switch_core_media.c: In function 'switch_core_media_patch_sdp':
-    src/switch_core_media.c:11854:4: error: 'strncpy' output truncated before terminating nul copying 2 bytes from a string of the same length [-Werror=stringop-truncation]
-        strncpy(q, strchr(a_engine->adv_sdp_ip, ':') ? "6 " : "4 ", 2);
-        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-    
-    This commit follows gcc's recommendation.
-    
-    Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
-
---- a/src/switch_core_media.c
-+++ b/src/switch_core_media.c
-@@ -11918,7 +11918,7 @@ SWITCH_DECLARE(void) switch_core_media_p
-                       strncpy(q, p, 7);
-                       p += 7;
-                       q += 7;
--                      strncpy(q, strchr(a_engine->adv_sdp_ip, ':') ? "6 " : "4 ", 2);
-+                      memcpy(q, strchr(a_engine->adv_sdp_ip, ':') ? "6 " : "4 ", 2);
-                       p +=2;
-                       q +=2;
-                       strncpy(q, a_engine->adv_sdp_ip, strlen(a_engine->adv_sdp_ip));
diff --git a/net/freeswitch-stable/patches/410-mod_say_ja-fix-format-overflow.patch b/net/freeswitch-stable/patches/410-mod_say_ja-fix-format-overflow.patch
deleted file mode 100644 (file)
index b9f598f..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-commit 3ca75eb8efa4e50ebe083a269b75fcb1762daa91
-Author: Sebastian Kemper <sebastian_ml@gmx.net>
-Date:   Sun Apr 14 19:23:41 2019 +0200
-
-    FS-11783: [mod_say_ja] quiet overflow warning
-    
-    With -Wformat-overflow gcc warns about calls to formatted input/output
-    function "sprintf" that might overflow the destination buffer.
-    
-    In this case gcc does not know the upper bound of tm_min and assumes
-    that up to 11 bytes might be written to buffer (3 bytes). But we know
-    that tm_min can only be within the range 0 to 59.
-    
-    mod_say_ja.c: In function 'ja_say_time':
-    mod_say_ja.c:376:35: error: '%d' directive writing between 2 and 10 bytes into a region of size 3 [-Werror=format-overflow=]
-                      sprintf(buffer, "%d", tm.tm_min);
-                                       ^~
-    mod_say_ja.c:376:34: note: directive argument in the range [11, 2147483647]
-                      sprintf(buffer, "%d", tm.tm_min);
-                                      ^~~~
-    mod_say_ja.c:376:18: note: 'sprintf' output between 3 and 11 bytes into a destination of size 3
-                      sprintf(buffer, "%d", tm.tm_min);
-                      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-    
-    This commits adds a hint for gcc, which silences the warning.
-    
-    Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
-
-diff --git a/src/mod/say/mod_say_ja/mod_say_ja.c b/src/mod/say/mod_say_ja/mod_say_ja.c
-index 72c7c38131..d8e0692fd0 100644
---- a/src/mod/say/mod_say_ja/mod_say_ja.c
-+++ b/src/mod/say/mod_say_ja/mod_say_ja.c
-@@ -367,7 +367,8 @@ static switch_status_t ja_say_time(switch_core_session_t *session, char *tosay,
-                       say_file("time/pm.wav");
-               }
-               say_file("time/hour-%d.wav", tm.tm_hour);
--              if (tm.tm_min > 10) {
-+              /* tm_min is always < 60 - this is just to silence gcc 8 warning */
-+              if (tm.tm_min > 10 && tm.tm_min < 60) {
-                       int temp;
-                       char tch[1+1];
-                       mod_min = tm.tm_min % 10;
diff --git a/net/freeswitch-stable/patches/420-mod_kazoo-correct-ei_init-check.patch b/net/freeswitch-stable/patches/420-mod_kazoo-correct-ei_init-check.patch
deleted file mode 100644 (file)
index 4381643..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/mod/event_handlers/mod_kazoo/kazoo_ei_utils.c
-+++ b/src/mod/event_handlers/mod_kazoo/kazoo_ei_utils.c
-@@ -519,7 +519,7 @@ switch_status_t create_acceptor() {
-     char ipbuf[48];
-     const char *ip_addr;
--#if ERLANG_MAJOR >= 10
-+#if (ERLANG_MAJOR == 10 && ERLANG_MINOR >= 3) || ERLANG_MAJOR >= 11
-     ei_init();
- #endif