[packages] glib2: Update to v2.26.1
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 2 Feb 2011 19:01:16 +0000 (19:01 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 2 Feb 2011 19:01:16 +0000 (19:01 +0000)
SVN-Revision: 25320

libs/glib2/Makefile
libs/glib2/patches/001-automake-compat.patch
libs/glib2/patches/010-move-iconv-to-libs.patch
libs/glib2/patches/020-no-docs-tests-translations.patch

index 622f8ae7775571430df0ac3d20b951e0388b60c4..299e1d038934a2cb93857f68ba94cbf9654e646c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
-PKG_VERSION:=2.22.2
+PKG_VERSION:=2.26.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
-PKG_SOURCE_URL:=@GNOME/glib/2.22
-PKG_MD5SUM:=846a86c74b74d5b16826aa5508940f9b
+PKG_SOURCE_URL:=@GNOME/glib/2.26
+PKG_MD5SUM:=17535accceef55bcb17a74d73f9c2aef
 
 PKG_FIXUP:=libtool
 PKG_BUILD_DEPENDS:=glib2/host
index 1d886d13238e32c0aea313debdbeac1a2fd8462a..aa6833a4b96462e680586c8a21fe8be91a07fb6e 100644 (file)
@@ -1,10 +1,10 @@
---- a/configure.in
-+++ b/configure.in
-@@ -2682,7 +2682,8 @@ dnl **************************
+--- a/configure.ac
++++ b/configure.ac
+@@ -2741,7 +2741,8 @@ dnl **************************
  dnl *** Checks for gtk-doc ***
  dnl **************************
  
--GTK_DOC_CHECK([1.11])
+-GTK_DOC_CHECK([1.15])
 +AM_CONDITIONAL([ENABLE_GTK_DOC], [false])
 +AM_CONDITIONAL([GTK_DOC_USE_LIBTOOL], [false])
  
index 17b936009fc6785a91176d466af3f969de04c7fa..89b3fea854458bae6effaf81b653dc152bf3df58 100644 (file)
@@ -1,6 +1,6 @@
---- glib-2.18.1/glib-2.0.pc.in.orig    2008-10-03 22:32:17.000000000 +0200
-+++ glib-2.18.1/glib-2.0.pc.in 2008-10-03 22:32:42.000000000 +0200
-@@ -10,6 +10,5 @@
+--- a/glib-2.0.pc.in
++++ b/glib-2.0.pc.in
+@@ -10,6 +10,5 @@ glib_mkenums=glib-mkenums
  Name: GLib
  Description: C Utility Library
  Version: @VERSION@
index 0ecac86f2f10e24e989b9f556bf19571b1ec7006..0460640e19fc1bcefa3e8258ad18d60cb3a820e3 100644 (file)
@@ -1,61 +1,6 @@
---- a/gio/Makefile.in
-+++ b/gio/Makefile.in
-@@ -242,7 +242,7 @@ ETAGS = etags
- CTAGS = ctags
- am__tty_colors = \
- red=; grn=; lgn=; blu=; std=
--DIST_SUBDIRS = libasyncns xdgmime inotify fen win32 . fam tests
-+DIST_SUBDIRS = libasyncns xdgmime inotify fen . fam
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- am__relativize = \
-   dir0=`pwd`; \
-@@ -489,7 +489,7 @@ EXTRA_DIST = gio-marshal.list gio.symbol
- TEST_PROGS = 
- NULL = 
- SUBDIRS = $(am__append_1) $(am__append_2) $(am__append_6) \
--      $(am__append_9) . $(am__append_12) tests
-+      $(am__append_9) . $(am__append_12)
- @MS_LIB_AVAILABLE_TRUE@@OS_WIN32_AND_DLL_COMPILATION_TRUE@noinst_DATA = gio-2.0.lib
- @MS_LIB_AVAILABLE_TRUE@@OS_WIN32_AND_DLL_COMPILATION_TRUE@install_ms_lib_cmd = $(INSTALL) gio-2.0.lib $(DESTDIR)$(libdir)
- @MS_LIB_AVAILABLE_TRUE@@OS_WIN32_AND_DLL_COMPILATION_TRUE@uninstall_ms_lib_cmd = -rm $(DESTDIR)$(libdir)/gio-2.0.lib
---- a/glib/Makefile.in
-+++ b/glib/Makefile.in
-@@ -483,8 +483,8 @@ TEST_PROGS = 
- @ENABLE_REGEX_TRUE@gregex_c = gregex.c
- @ENABLE_REGEX_FALSE@gregex_h = 
- @ENABLE_REGEX_TRUE@gregex_h = gregex.h
--SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
--DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
-+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
-+DIST_SUBDIRS = libcharset gnulib pcre update-pcre
- AM_CPPFLAGS = \
-       -I$(top_srcdir)                 \
-       $(pcre_inc)                     \
---- a/gobject/Makefile.in
-+++ b/gobject/Makefile.in
-@@ -413,7 +413,7 @@ TEST_PROGS = 
- # GObject - GLib Type, Object, Parameter and Signal Library
- # Copyright (C) 1997,98,99,2000 Tim Janik and Red Hat, Inc.
- #
--SUBDIRS = . tests
-+SUBDIRS = .
- AM_CPPFLAGS = \
-       -DG_LOG_DOMAIN=\"GLib-GObject\"         \
-       -I$(top_srcdir)                         \
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -398,7 +398,7 @@ EXTRA_DIST = ChangeLog.pre-2-20 ChangeLo
-       gio-2.0-uninstalled.pc.in gio-unix-2.0-uninstalled.pc.in
- TEST_PROGS = 
- AUTOMAKE_OPTIONS = 1.7
--SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
-+SUBDIRS = . m4macros glib gmodule gthread gobject gio
- DIST_SUBDIRS = $(SUBDIRS) build
- bin_SCRIPTS = glib-gettextize
- AM_CPPFLAGS = \
---- a/configure.in
-+++ b/configure.in
-@@ -3470,18 +3470,6 @@ gio/fen/Makefile
+--- a/configure.ac
++++ b/configure.ac
+@@ -3737,18 +3737,6 @@ gio/fen/Makefile
  gio/fam/Makefile
  gio/win32/Makefile
  gio/tests/Makefile
@@ -76,7 +21,7 @@
  
 --- a/gio/Makefile.am
 +++ b/gio/Makefile.am
-@@ -174,8 +174,6 @@ win32_sources = \
+@@ -264,8 +264,6 @@ giowin32include_HEADERS = \
  
  endif
  
  libgio_2_0_la_SOURCES =               \
        gappinfo.c              \
        gasynchelper.c          \
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -3,7 +3,7 @@ include $(top_srcdir)/Makefile.decl
- AUTOMAKE_OPTIONS = 1.7
--SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
-+SUBDIRS = . m4macros glib gmodule gthread gobject gio
- DIST_SUBDIRS = $(SUBDIRS) build
- bin_SCRIPTS = glib-gettextize
 --- a/glib/Makefile.am
 +++ b/glib/Makefile.am
-@@ -19,7 +19,7 @@ gregex_c =
- gregex_h =
+@@ -48,9 +48,9 @@ else
+ gatomic_c = gatomic.c
  endif
  
 -SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
 +SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
  
- DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
+-DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
++DIST_SUBDIRS = libcharset gnulib pcre update-pcre
  
+ AM_CPPFLAGS =                                 \
+       $(glib_INCLUDES)                \
 --- a/gobject/Makefile.am
 +++ b/gobject/Makefile.am
 @@ -4,7 +4,7 @@
 -SUBDIRS = . tests
 +SUBDIRS = .
  
- AM_CPPFLAGS =                                         \
-       -DG_LOG_DOMAIN=\"GLib-GObject\"         \
+ CLEANFILES=
+--- a/gthread/Makefile.am
++++ b/gthread/Makefile.am
+@@ -1,8 +1,8 @@
+ ## Process this file with automake to produce Makefile.in
+ include $(top_srcdir)/Makefile.decl
+-SUBDIRS = . tests
+-DIST_SUBDIRS = tests
++SUBDIRS = .
++DIST_SUBDIRS = 
+ AM_CPPFLAGS =                                 \
+       $(glib_INCLUDES)                \
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -3,7 +3,7 @@ include $(top_srcdir)/Makefile.decl
+ ACLOCAL_AMFLAGS = -I m4macros ${ACLOCAL_FLAGS}
+-SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
++SUBDIRS = . m4macros glib gmodule gthread gobject gio
+ DIST_SUBDIRS = $(SUBDIRS) build
+ bin_SCRIPTS = glib-gettextize