Beautify "make help"
authorJohn Tsichritzis <john.tsichritzis@arm.com>
Tue, 21 May 2019 14:57:31 +0000 (15:57 +0100)
committerJohn Tsichritzis <john.tsichritzis@arm.com>
Fri, 24 May 2019 09:00:01 +0000 (10:00 +0100)
Changes to make the help text a bit more readable:
1) The "usage" part is now a one-liner
2) The supported platforms list is printed separately

Change-Id: I93e48a6cf1d28f0ef9f3db16ce17725e4dff33c9
Signed-off-by: John Tsichritzis <john.tsichritzis@arm.com>
Makefile

index 976f514dda3200a220841572fff36fa70c0fc207..037395fa678892be8004c16b1503f31a1cea1ab5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -909,11 +909,13 @@ cscope:
        ${Q}cscope -b -q -k
 
 help:
-       @echo "usage: ${MAKE} PLAT=<${PLATFORM_LIST}> [OPTIONS] [TARGET]"
+       @echo "usage: ${MAKE} [PLAT=<platform>] [OPTIONS] [TARGET]"
        @echo ""
        @echo "PLAT is used to specify which platform you wish to build."
        @echo "If no platform is specified, PLAT defaults to: ${DEFAULT_PLAT}"
        @echo ""
+       @echo "platform = ${PLATFORM_LIST}"
+       @echo ""
        @echo "Please refer to the User Guide for a list of all supported options."
        @echo "Note that the build system doesn't track dependencies for build "
        @echo "options. Therefore, if any of the build options are changed "