nginx: update ubus module to fix SIGSEGV 13323/head
authorAnsuel Smith <ansuelsmth@gmail.com>
Mon, 7 Sep 2020 12:58:51 +0000 (14:58 +0200)
committerAnsuel Smith <ansuelsmth@gmail.com>
Mon, 7 Sep 2020 13:01:19 +0000 (15:01 +0200)
- Bump relase
- Bump nginx_ubus_module version

Fixes #13314

Reported-by: Chen Minqiang <ptpt52@gmail.com>
Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
net/nginx/Makefile

index b8bfb45b3c6642b2af4ff02a1598800c67dbd3cc..4ea2c19e12b25438f9b087f563db5b608fa3d116 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
 PKG_VERSION:=1.19.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://nginx.org/download/
@@ -526,11 +526,11 @@ endif
 
 ifeq ($(CONFIG_NGINX_UBUS),y)
   define Download/nginx-ubus-module
-    VERSION:=5251367fbf8f31611ca642669a08addedc6e3665
+    VERSION:=b2d7260dcb428b2fb65540edb28d7538602b4a26
     SUBDIR:=nginx-ubus-module
     FILE:=nginx-ubus-module-$$(VERSION).tar.xz
     URL:=https://github.com/Ansuel/nginx-ubus-module.git
-    MIRROR_HASH:=9c1c1e8cad908b44881cb5c2c2285f51546ad8d92754576eb2fd025e04414670
+    MIRROR_HASH:=472cef416d25effcac66c85417ab6596e634a7a64d45b709bb090892d567553c
     PROTO:=git
   endef
   $(eval $(call Download,nginx-ubus-module))