psqlodbc: build against staging libs
authorDaniel Golle <daniel@makrotopia.org>
Sat, 8 Jul 2017 10:42:41 +0000 (12:42 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 8 Jul 2017 10:44:20 +0000 (12:44 +0200)
avoid accidentally picking paths on the host for pg_config and
odbc_config by supplying them as parameters to configure.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/psqlodbc/Makefile

index 28814832842e9bf39891ab10b4379c54f00ce6e1..ddd9aac7f3a1018b76fe81548b80d0a25896a020 100644 (file)
@@ -19,6 +19,10 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+CONFIGURE_ARGS += \
+       --with-unixodbc=$(STAGING_DIR)/usr \
+       --with-libpq=$(STAGING_DIR)/usr
+
 define Package/psqlodbc/Default
   SUBMENU:=database
   URL:=https://odbc.postgresql.org/