python,python3: get rid of HOST_CFLAGS
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 7 Nov 2016 07:46:47 +0000 (09:46 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 7 Nov 2016 08:55:33 +0000 (10:55 +0200)
They rely on system paths and are a bit misleading/confusing.
As seen here:
https://github.com/openwrt/packages/issues/3339

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/Makefile
lang/python3/Makefile

index 687481faba918826c57f9ff96e0da205fcec3453..3235b4557e27cce29efc68d0e77b2ca8f1a1bb62 100644 (file)
@@ -220,10 +220,6 @@ define PyPackage/python/filespec
 -|$(PYTHON_PKG_DIR)
 endef
 
-HOST_CFLAGS+= \
-       -I/usr/include/ncursesw \
-       -I/usr/include/ncurses
-
 HOST_CONFIGURE_ARGS+= \
        --without-cxx-main \
        --without-pymalloc \
index 2d177ab3a5d14135ab5a068a831dd441c8584542..c46f3bd566cd918882c573f65fa7815ea3986a4b 100644 (file)
@@ -208,10 +208,6 @@ define Py3Package/python3/filespec
 -|$(PYTHON3_PKG_DIR)
 endef
 
-HOST_CFLAGS+= \
-       -I/usr/include/ncursesw \
-       -I/usr/include/ncurses
-
 HOST_CONFIGURE_ARGS+= \
        --without-cxx-main \
        --without-pymalloc \