python-trove-classifiers: Add new host-only package
authorJeffery To <jeffery.to@gmail.com>
Fri, 14 Apr 2023 08:03:02 +0000 (16:03 +0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 1 May 2023 10:34:40 +0000 (13:34 +0300)
From the README:

Canonical source for classifiers on PyPI.

Classifiers categorize projects per PEP 301. Use this package to
validate classifiers in packages for PyPI upload or download.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-trove-classifiers/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-trove-classifiers/Makefile b/lang/python/python-trove-classifiers/Makefile
new file mode 100644 (file)
index 0000000..b122bc2
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-trove-classifiers
+PKG_VERSION:=2023.3.9
+PKG_RELEASE:=1
+
+PYPI_NAME:=trove-classifiers
+PKG_HASH:=ee42f2f8c1d4bcfe35f746e472f07633570d485fab45407effc0379270a3bb03
+
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+PKG_BUILD_DEPENDS:=python-calver/host
+HOST_BUILD_DEPENDS:= \
+       python3/host \
+       python-build/host \
+       python-installer/host \
+       python-wheel/host \
+       python-calver/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-trove-classifiers
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Canonical source for classifiers on PyPI (pypi.org).
+  URL:=https://github.com/pypa/trove-classifiers
+  DEPENDS:=+python3-light
+  BUILDONLY:=1
+endef
+
+define Package/python3-trove-classifiers/description
+Canonical source for classifiers on PyPI.
+
+Classifiers categorize projects per PEP 301. Use this package to
+validate classifiers in packages for PyPI upload or download.
+endef
+
+$(eval $(call Py3Package,python3-trove-classifiers))
+$(eval $(call BuildPackage,python3-trove-classifiers))
+$(eval $(call BuildPackage,python3-trove-classifiers-src))
+$(eval $(call HostBuild))