port iptables fix introduced by changeset:2447 to trunk
authorNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2005 11:53:55 +0000 (11:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2005 11:53:55 +0000 (11:53 +0000)
SVN-Revision: 2448

openwrt/package/iptables/Makefile
openwrt/target/linux/netfilter.mk

index f54481c05b958a83606f9e1594f1ceb91e2e8030..cdbb866a09ca5424aeb5433bb58d0d8743a85d59 100644 (file)
@@ -75,7 +75,7 @@ $(IPKG_IPTABLES):
        cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
        install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
-               cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y) ipt_standard) $(IDIR_IPTABLES)/usr/lib/iptables/ \
+               cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
        )
        $(RSTRIP) $(IDIR_IPTABLES)
        $(IPKG_BUILD) $(IDIR_IPTABLES) $(PACKAGE_DIR)
index 433c386d6ecc9580f31fe32fc73da20550b3dd52..6375a71f215ed1fc248e0e6b6deaba36b6c137d5 100644 (file)
@@ -71,7 +71,7 @@ IPKG_KMOD_IPT_ULOG-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG
 #\r
 \r
 IPKG_IPTABLES-y := ipt_standard\r
-IPKG_IPTABLES-y := ipt_icmp ipt_tcp ipt_udp\r
+IPKG_IPTABLES-y += ipt_icmp ipt_tcp ipt_udp\r
 \r
 IPKG_IPTABLES_MOD_CONNTRACK-m :=\r
 IPKG_IPTABLES_MOD_CONNTRACK-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark\r