open-vm-tools: update to 12.1.5
authorOskari Rauta <oskari.rauta@gmail.com>
Wed, 22 Feb 2023 17:19:19 +0000 (17:19 +0000)
committerTianling Shen <cnsztl@gmail.com>
Sat, 4 Mar 2023 00:39:46 +0000 (08:39 +0800)
added also --disable-glibc-check to configure args to allow building
on hosts that use musl.

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
utils/open-vm-tools/Makefile
utils/open-vm-tools/patches/0002-off64_t.patch
utils/open-vm-tools/patches/0015-i386-time.patch [deleted file]
utils/open-vm-tools/patches/010-warnings.patch

index 0f4ccc5dba7056b8b1149702438d22e3d7d06aec..172639304d45b2845eac1f8316d576ab8e28ba3f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=open-vm-tools
-PKG_VERSION:=12.0.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=12.1.5
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-19345655.tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-20735119.tar.gz
 PKG_SOURCE_URL:=https://github.com/vmware/open-vm-tools/releases/download/stable-$(PKG_VERSION)
-PKG_HASH:=ea370217a213802f91b01231e28298bbe54134822351fb5cc70255d80ba0e775
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-19345655
+PKG_HASH:=72cb68c71c59fd429bcb357926f41f07e21c737a341534b707fc1df010ed4868
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-20735119
 
 PKG_LICENSE:=LGPL-2.1-or-later
 PKG_LICENSE_FILES:=LICENSE
@@ -80,7 +80,8 @@ CONFIGURE_ARGS+= \
        --without-gtk2 \
        --without-gtk3 \
        --without-xerces \
-       --enable-resolutionkms=no
+       --enable-resolutionkms=no \
+       --disable-glibc-check
 
 TARGET_LDFLAGS+=$(if $(ICONV_FULL),-liconv)
 
index d4b34ce90e7cb519cede2c235185dbce806e5a39..aaf330d5f0c3d1e952afc8cdc786e97ae63511c2 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
 
 --- a/lib/file/fileIOPosix.c
 +++ b/lib/file/fileIOPosix.c
-@@ -198,7 +198,7 @@ static AlignedPool alignedPool;
+@@ -203,7 +203,7 @@ static AlignedPool alignedPool;
   * are not available in any header file.
   */
  
diff --git a/utils/open-vm-tools/patches/0015-i386-time.patch b/utils/open-vm-tools/patches/0015-i386-time.patch
deleted file mode 100644 (file)
index 30cb63e..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-From 3f0580f2546de8be7acf1bc78a55a257bc638ebe Mon Sep 17 00:00:00 2001
-From: Bartosz Brachaczek <b.brachaczek@gmail.com>
-Date: Tue, 12 Nov 2019 14:31:08 +0100
-Subject: [PATCH] Make HgfsConvertFromNtTimeNsec aware of 64-bit time_t on i386
-
-I verified that this function behaves as expected on x86_64, i386 with
-32-bit time_t, and i386 with 64-bit time_t for the following values of
-ntTtime:
-
-UNIX_EPOCH-1, UNIX_EPOCH, UNIX_EPOCH+1, UNIX_S32_MAX-1, UNIX_S32_MAX,
-UNIX_S32_MAX+1, UNIX_S32_MAX*2+1
-
-I did not verify whether the use of Div643264 is optimal, performance
-wise.
----
- lib/hgfs/hgfsUtil.c | 34 +++++++++++++++++--------------
- 1 file changed, 19 insertions(+), 15 deletions(-)
-
---- a/lib/hgfs/hgfsUtil.c
-+++ b/lib/hgfs/hgfsUtil.c
-@@ -110,23 +110,21 @@ HgfsConvertFromNtTimeNsec(struct timespe
-                         uint64 ntTime) // IN: Time in Windows NT format
- {
- #ifdef __i386__
--   uint32 sec;
--   uint32 nsec;
-+   uint64 sec64;
-+   uint32 sec32, nsec;
-+#endif
-    ASSERT(unixTime);
--   /* We assume that time_t is 32bit */
--   ASSERT_ON_COMPILE(sizeof (unixTime->tv_sec) == 4);
--   /* Cap NT time values that are outside of Unix time's range */
-+   if (sizeof (unixTime->tv_sec) == 4) {
-+      /* Cap NT time values that are outside of Unix time's range */
--   if (ntTime >= UNIX_S32_MAX) {
--      unixTime->tv_sec = 0x7FFFFFFF;
--      unixTime->tv_nsec = 0;
--      return 1;
-+      if (ntTime >= UNIX_S32_MAX) {
-+         unixTime->tv_sec = 0x7FFFFFFF;
-+         unixTime->tv_nsec = 0;
-+         return 1;
-+      }
-    }
--#else
--   ASSERT(unixTime);
--#endif
-    if (ntTime < UNIX_EPOCH) {
-       unixTime->tv_sec = 0;
-@@ -135,9 +133,15 @@ HgfsConvertFromNtTimeNsec(struct timespe
-    }
- #ifdef __i386__
--   Div643232(ntTime - UNIX_EPOCH, 10000000, &sec, &nsec);
--   unixTime->tv_sec = sec;
--   unixTime->tv_nsec = nsec * 100;
-+   if (sizeof (unixTime->tv_sec) == 4) {
-+      Div643232(ntTime - UNIX_EPOCH, 10000000, &sec32, &nsec);
-+      unixTime->tv_sec = sec32;
-+      unixTime->tv_nsec = nsec * 100;
-+   } else {
-+      Div643264(ntTime - UNIX_EPOCH, 10000000, &sec64, &nsec);
-+      unixTime->tv_sec = sec64;
-+      unixTime->tv_nsec = nsec * 100;
-+   }
- #else
-    unixTime->tv_sec = (ntTime - UNIX_EPOCH) / 10000000;
-    unixTime->tv_nsec = ((ntTime - UNIX_EPOCH) % 10000000) * 100;
index 3b459641085f486c99cdcbca88cdb1a6eb34b82c..6681586a9b12510031338096e505112193995fc9 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/lib/file/fileIOPosix.c
 +++ b/lib/file/fileIOPosix.c
-@@ -1741,7 +1741,7 @@ FileIOPreadvInternal(
+@@ -1746,7 +1746,7 @@ FileIOPreadvInternal(
         * the library horizon this can go away.
         */
        /* coverity[func_conv] */
@@ -19,7 +19,7 @@
           fret = FileIOPreadvCoalesced(fd, entries, numEntries, offset,
                                        totalSize, &bytesRead);
           break;
-@@ -1882,7 +1882,7 @@ FileIOPwritevInternal(
+@@ -1887,7 +1887,7 @@ FileIOPwritevInternal(
         * the library horizon this can go away.
         */
        /* coverity[func_conv] */