pcapsipdump: version bump to 0.2
authorJiri Slachta <slachta@cesnet.cz>
Sun, 25 Aug 2013 19:49:54 +0000 (21:49 +0200)
committerJiri Slachta <slachta@cesnet.cz>
Sun, 25 Aug 2013 19:49:54 +0000 (21:49 +0200)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
net/pcapsipdump/Makefile
net/pcapsipdump/patches/001-cross_compile.patch [deleted file]
net/pcapsipdump/patches/002-elif_else_replacement.patch [deleted file]

index ad077469548124941ff932e492293753efb9b796..dfbf2c984f2821e664061be488c8728342a5cfc3 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcapsipdump
-PKG_VERSION:=0.1.4
-PKG_RELEASE:=3
+PKG_VERSION:=0.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/psipdump
-PKG_MD5SUM:=95ed26caf66237a654cae2cacdaa3386
+PKG_SOURCE_URL:=@SF/pcapsipdump
+PKG_MD5SUM:=2c04c54c3478f7cb94978d54538006d2
 
 include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
@@ -28,9 +28,9 @@ define Package/pcapsipdump
 endef
 
 define Package/pcapsipdump/description
       pcapsipdump is a tool for dumping SIP sessions (+RTP traffic, if available) to disk in a
       fashion similar to "tcpdump -w" (format is exactly the same), but one file per sip session
       (even if there is thousands of concurrect SIP sessions).
+ pcapsipdump is a tool for dumping SIP sessions (+RTP traffic, if available) to disk in a
+ fashion similar to "tcpdump -w" (format is exactly the same), but one file per sip session
+ (even if there is thousands of concurrect SIP sessions).
 endef
 
 TARGET_CC=$(TARGET_CXX)
diff --git a/net/pcapsipdump/patches/001-cross_compile.patch b/net/pcapsipdump/patches/001-cross_compile.patch
deleted file mode 100644 (file)
index db4bead..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -urN pcapsipdump-0.1.4/Makefile pcapsipdump-0.1.4.new/Makefile
---- pcapsipdump-0.1.4/Makefile 2007-02-09 12:33:48.000000000 +0100
-+++ pcapsipdump-0.1.4.new/Makefile     2009-05-12 12:01:02.000000000 +0200
-@@ -1,10 +1,10 @@
- all: pcapsipdump
- pcapsipdump: pcapsipdump.cpp calltable.cpp calltable.h
--      $(CC) $(CPPFLAGS) $(LDFLAGS) pcapsipdump.cpp calltable.cpp -o pcapsipdump -lpcap -lstdc++
-+      $(CC) $(CPPFLAGS) $(LDFLAGS) pcapsipdump.cpp calltable.cpp -o pcapsipdump $(LIBS)
- pcapsipdump-debug: pcapsipdump.cpp calltable.cpp calltable.h
--      $(CC) $(CPPFLAGS) $(LDFLAGS) -ggdb pcapsipdump.cpp calltable.cpp -o pcapsipdump-debug -lpcap -lstdc++
-+      $(CC) $(CPPFLAGS) $(LDFLAGS) -ggdb pcapsipdump.cpp calltable.cpp -o pcapsipdump-debug $(LIBS)
- clean:
-       rm -f pcapsipdump
diff --git a/net/pcapsipdump/patches/002-elif_else_replacement.patch b/net/pcapsipdump/patches/002-elif_else_replacement.patch
deleted file mode 100644 (file)
index bb217b7..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN pcapsipdump-0.1.4/pcapsipdump.h pcapsipdump-0.1.4.new/pcapsipdump.h
---- pcapsipdump-0.1.4/pcapsipdump.h    2007-05-11 20:40:49.000000000 +0200
-+++ pcapsipdump-0.1.4.new/pcapsipdump.h        2010-03-29 09:52:20.000000000 +0200
-@@ -35,7 +35,7 @@
- #elif defined (__BIG_ENDIAN)
-       uint8_t version:4,
-               ihl:4;
--#elif
-+#else
- #error Endian not defined
- #endif
-       uint8_t tos;