Merge pull request #23874 from stangri/openwrt-23.05-adblock-fast
authorStan Grishin <stangri@melmac.ca>
Fri, 12 Apr 2024 20:39:55 +0000 (13:39 -0700)
committerGitHub <noreply@github.com>
Fri, 12 Apr 2024 20:39:55 +0000 (13:39 -0700)
[23.05] adblock-fast: improve Makefile's prerm

lang/lualanes/Makefile
lang/lualanes/patches/100-musl-compat.patch [deleted file]
lang/lualanes/patches/200-fix-redef-error.patch [deleted file]
net/curl/Makefile
net/curl/patches/200-no_docs_tests.patch
utils/hwdata/Makefile

index 16395b43be27d71825267ea022fde0ba6f1dbafb..764b8ddd0e7c0e3660e3a38db288ef9d82a7b9f7 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lualanes
-PKG_VERSION:=3.13.0
-PKG_RELEASE:=2
+PKG_VERSION:=3.16.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/LuaLanes/lanes/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=53a17d7ee11f17ca0543ae5aa640208dcb62d37862a0d0ea450455fae12c8ff1
+PKG_HASH:=22cfa836de4be14fe588b9cd34e936d6f61ec6f4096d8ae30d4ec35855d9608f
 PKG_BUILD_DIR:=$(BUILD_DIR)/lanes-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Vladimir Malyutin <first-leon@yandex.ru>
@@ -35,7 +35,7 @@ define Package/lualanes
 endef
 
 define Package/lualanes/description
- Lua Lanes is a Lua extension library providing the possibility to run
+Lua Lanes is a Lua extension library providing the possibility to run
 multiple Lua states in parallel. It is intended to be used for optimizing
 performance on multicore CPU's and to study ways to make Lua programs
 naturally parallel to begin with.
diff --git a/lang/lualanes/patches/100-musl-compat.patch b/lang/lualanes/patches/100-musl-compat.patch
deleted file mode 100644 (file)
index 4edabf7..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/threading.h
-+++ b/src/threading.h
-@@ -110,7 +110,7 @@ enum e_status { PENDING, RUNNING, WAITIN
-   #endif // PLATFORM_WIN32
-   #include <pthread.h>
--  #ifdef PLATFORM_LINUX
-+  #if defined(PLATFORM_LINUX) && defined(__GLIBC__)
-   # define _MUTEX_RECURSIVE PTHREAD_MUTEX_RECURSIVE_NP
-   #else
-     /* OS X, ... */
diff --git a/lang/lualanes/patches/200-fix-redef-error.patch b/lang/lualanes/patches/200-fix-redef-error.patch
deleted file mode 100644 (file)
index 662e08f..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/threading.c
-+++ b/src/threading.c
-@@ -35,7 +35,9 @@ THE SOFTWARE.
- ===============================================================================
- */
- #if defined(__linux__)
-+#ifndef _GNU_SOURCE
- # define _GNU_SOURCE /* must be defined before any include */
-+#endif
- # ifdef __ANDROID__
- #  include <android/log.h>
- #  define LOG_TAG "LuaLanes"
index 1969d2dee7dfc4cc199ff62badc97c7e73c20935..5ad13c4c5cd0b7c710839ec10f51a616b54eadc9 100644 (file)
@@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/nls.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=8.6.0
-PKG_RELEASE:=1
+PKG_VERSION:=8.7.1
+PKG_RELEASE:=r1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,$(PKG_VERSION))/ \
        https://dl.uxnr.de/mirror/curl/ \
        https://curl.askapache.com/download/ \
        https://curl.se/download/
-PKG_HASH:=b4785f2d8877fa92c0e45d7155cf8cc6750dbda961f4b1a45bcbec990cf2fa9b
+PKG_HASH:=05bbd2b698e9cfbab477c33aa5e99b4975501835a41b7ca6ca71de03d8849e76
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -113,6 +113,7 @@ TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_ARGS += \
        --disable-debug \
+       --disable-docs \
        --disable-ares \
        --enable-shared \
        --enable-static \
index 4e0ec1aa3e65ec801e75802d50d42b6c5e32068b..9284b67e5feaee073ffc8155f682358918038bb2 100644 (file)
@@ -3,18 +3,22 @@
 @@ -135,7 +135,7 @@ CLEANFILES = $(VC14_LIBVCXPROJ) $(VC14_S
  bin_SCRIPTS = curl-config
  
- SUBDIRS = lib src
+ SUBDIRS = lib docs src scripts
 -DIST_SUBDIRS = $(SUBDIRS) tests packages scripts include docs
 +DIST_SUBDIRS = $(SUBDIRS) packages include
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -243,8 +243,6 @@ cygwinbin:
- # We extend the standard install with a custom hook:
+@@ -244,12 +244,9 @@ cygwinbin:
+ if BUILD_DOCS
  install-data-hook:
        (cd include && $(MAKE) install)
 -      (cd docs && $(MAKE) install)
 -      (cd docs/libcurl && $(MAKE) install)
+ else
+ install-data-hook:
+       (cd include && $(MAKE) install)
+-      (cd docs && $(MAKE) install)
+ endif
  
  # We extend the standard uninstall with a custom hook:
- uninstall-hook:
index 0ced19e0175ffefac012ea65cdf65140b8e272a8..8487a1b63ee42e73839ec65346c8c7f462a173ad 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hwdata
-PKG_VERSION:=0.359
+PKG_VERSION:=0.379
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/vcrhonek/hwdata/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=07bf89f5a1b341427536b4fffe300c7848988367a1bce20fc4b1ab7e7629f861
+PKG_HASH:=b98ef646d530d5fd3afa3180efbf7c8e22d3da0088f5836f41ee25380d87b092
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=GPL-2.0-or-later  XFree86-1.0