ffmpeg: Add cpu_type to configure opts. Upgrade to 3.2.12 6743/head
authorTed Hess <thess@kitschensync.net>
Sun, 12 Aug 2018 21:36:28 +0000 (17:36 -0400)
committerTed Hess <thess@kitschensync.net>
Sun, 12 Aug 2018 21:36:28 +0000 (17:36 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
multimedia/ffmpeg/Makefile

index 4f29945fc36c99d8f1055142510e0dc5543367a5..0c4c08052c444cacc13e90793b1c12a792f19b4b 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
-PKG_VERSION:=3.2.10
-PKG_RELEASE:=4
+PKG_VERSION:=3.2.12
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://ffmpeg.org/releases/
-PKG_HASH:=3c1626220c7b68ff6be7312559f77f3c65ff6809daf645d4470ac0189926bdbc
+PKG_HASH:=8985cea7b1b3b2e0e2b2a8ac6187a7fb022fe8aa9d35101760a000205c59c412
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
                Ian Leonard <antonlacon@gmail.com>
 
@@ -372,6 +372,9 @@ $(call Package/ffmpeg/Default/description)
 endef
 
 
+# Strip off FPU notation
+REAL_CPU_TYPE:=$(firstword $(subst +, ,$(CONFIG_CPU_TYPE)))
+
 FFMPEG_CONFIGURE:= \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
@@ -379,6 +382,7 @@ FFMPEG_CONFIGURE:= \
        --enable-cross-compile \
        --cross-prefix="$(TARGET_CROSS)" \
        --arch="$(ARCH)" \
+       $(if $(REAL_CPU_TYPE),--cpu=$(call qstrip,$(REAL_CPU_TYPE)),) \
        --target-os=linux \
        --prefix="/usr" \
        --pkg-config="pkg-config" \