nginx: add http_sub_module and other fix 6510/head
authorAnsuel Smith <ansuelsmth@gmail.com>
Tue, 17 Jul 2018 19:44:31 +0000 (21:44 +0200)
committerAnsuel Smith <ansuelsmth@gmail.com>
Wed, 18 Jul 2018 02:02:14 +0000 (04:02 +0200)
Someone requested this module to be included, so create the config flag for it.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
net/nginx/Config.in
net/nginx/Config_ssl.in
net/nginx/Makefile

index 32e6d245b1ede260f0848337172afd27e59c3dd3..2a8ce3389699643c9c9bebf8ad88a0abfca78341 100644 (file)
@@ -202,6 +202,11 @@ config NGINX_HTTP_SECURE_LINK
        prompt "Enable HTTP secure link module"
        default n
        
+config NGINX_HTTP_SUB
+       bool
+       prompt "Enable HTTP sub module"
+       default n
+       
 config NGINX_HEADERS_MORE
        bool
        prompt "Enable Headers_more module"
index 3b18dbbc938c4696479b6f6483f4dabf1cf3ac46..4fc79016f6cdedd2de6c36ddff146380de7515b9 100644 (file)
@@ -194,6 +194,11 @@ config NGINX_HTTP_SECURE_LINK
        bool
        prompt "Enable HTTP secure link module"
        default n
+
+config NGINX_HTTP_SUB
+       bool
+       prompt "Enable HTTP sub module"
+       default n
        
 config NGINX_HEADERS_MORE
        bool
index 7a74291ec9118890e1c1d5fa8740299afb00cfe6..2c65ea72ef4402632714e70d0aeeb99401a8c8d5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
 PKG_VERSION:=1.15.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nginx.org/download/
@@ -261,6 +261,9 @@ ifneq ($(BUILD_VARIANT),all-module)
   ifeq ($(CONFIG_NGINX_HTTP_SECURE_LINK),y)
     ADDITIONAL_MODULES += --with-http_secure_link_module
   endif
+  ifeq ($(CONFIG_NGINX_HTTP_SUB),y)
+       ADDITIONAL_MODULES += --with-http_sub_module
+  endif
   ifeq ($(CONFIG_NGINX_HEADERS_MORE),y)
     ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/nginx-headers-more
   endif
@@ -283,7 +286,7 @@ else
   ADDITIONAL_MODULES += --with-http_ssl_module --add-module=$(PKG_BUILD_DIR)/nginx-naxsi/naxsi_src \
     --add-module=$(PKG_BUILD_DIR)/lua-nginx --with-ipv6 --with-http_stub_status_module --with-http_flv_module \
        --with-http_dav_module --with-http_auth_request_module --with-http_v2_module --with-http_realip_module \
-       --with-http_secure_link_module --add-module=$(PKG_BUILD_DIR)/nginx-headers-more \
+       --with-http_secure_link_module --with-http_sub_module --add-module=$(PKG_BUILD_DIR)/nginx-headers-more \
        --add-module=$(PKG_BUILD_DIR)/nginx-brotli --add-module=$(PKG_BUILD_DIR)/nginx-rtmp \
        --add-module=$(PKG_BUILD_DIR)/nginx-ts
   config_files += koi-utf koi-win win-utf fastcgi_params