add mtd-static package
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 14 Sep 2005 15:26:45 +0000 (15:26 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 14 Sep 2005 15:26:45 +0000 (15:26 +0000)
SVN-Revision: 1919

openwrt/package/mtd/Config.in
openwrt/package/mtd/Makefile
openwrt/package/mtd/ipkg/mtd.control

index df0b9bf37b0ce67f084f648d63eca1766b178cbd..a1b24a93588bf49133978dedae1cf1d339fe5a7c 100644 (file)
@@ -4,3 +4,9 @@ config BR2_PACKAGE_MTD
        help
         update utility for trx firmware images.
 
+config BR2_PACKAGE_MTD_STATIC
+       tristate "mtd - update utility for trx firmware images (statically linked)"
+       default n
+       help
+        update utility for trx firmware images (statically linked). To update
+        from other firmware or older OpenWrt releases.
index bfbb301e4c867fb2bc72440ac7e8421535a4deb9..18ebc903354362fe0738f6edb8767fd2170b9fbb 100644 (file)
@@ -3,13 +3,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME := mtd
-PKG_RELEASE := 1
+PKG_RELEASE := 2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MTD_STATIC,mtd-static,$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.prepared:
        mkdir -p $@
@@ -17,6 +18,7 @@ $(PKG_BUILD_DIR)/.prepared:
 
 $(PKG_BUILD_DIR)/.built:
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+       $(TARGET_CC) -static $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd-static mtd.c
        touch $@
 
 $(IPKG_MTD): 
@@ -24,3 +26,9 @@ $(IPKG_MTD):
        install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
        $(RSTRIP) $(IDIR_MTD)/sbin/*
        $(IPKG_BUILD) $(IDIR_MTD) $(PACKAGE_DIR)
+
+$(IPKG_MTD_STATIC): 
+       install -d -m0755 $(IDIR_MTD_STATIC)/sbin
+       install -m0755 $(PKG_BUILD_DIR)/mtd-static $(IDIR_MTD_STATIC)/sbin
+       $(RSTRIP) $(IDIR_MTD_STATIC)/sbin/*
+       $(IPKG_BUILD) $(IDIR_MTD_STATIC) $(PACKAGE_DIR)
index 102bd704c13c23252d620cb55c969ce0da5cc745..d75e5d9e36758230fc01b74f09b5e1eac1e2897c 100644 (file)
@@ -1,6 +1,6 @@
 Package: mtd
 Priority: optional
 Section: sys
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Maintainer: OpenWrt Developer <openwrt-devel@openwrt.org>
 Source: buildroot internal
 Description: Tool for modifying the flash chip