lang: lua: Add penlight library 670/head
authorKarl Palsson <karlp@remake.is>
Thu, 18 Dec 2014 15:14:09 +0000 (15:14 +0000)
committerKarl Palsson <karlp@remake.is>
Thu, 18 Dec 2014 15:14:09 +0000 (15:14 +0000)
Created new package for last current release of penlight.

Signed-off-by: Karl Palsson <karlp@remake.is>
lang/lua-penlight/Makefile [new file with mode: 0644]

diff --git a/lang/lua-penlight/Makefile b/lang/lua-penlight/Makefile
new file mode 100644 (file)
index 0000000..e06f4c2
--- /dev/null
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-penlight
+PKG_VERSION:=1.3.1
+PKG_RELEASE:=1
+PKG_BUILD_DIR:=$(BUILD_DIR)/Penlight-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/stevedonovan/Penlight/archive/
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILE:=LICENSE.md
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+  SUBMENU:=Lua
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Penlight
+  URL:=http://stevedonovan.github.io/Penlight/api/manual/01-introduction.md.html
+  DEPENDS:=+luafilesystem
+  MAINTAINER:= Karl Palsson <karlp@remake.is>
+endef
+
+define Package/$(PKG_NAME)/description
+  It is often said of Lua that it does not include batteries.
+  Penlight is the batteries.
+endef
+
+define Build/Compile
+       echo "Nothing to compile, pure lua package"
+endef
+
+define Package/$(PKG_NAME)/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua
+       $(CP) $(PKG_BUILD_DIR)/lua/pl $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))