packages: znc: update to 1.2
authorJonas Gorski <jogo@openwrt.org>
Thu, 19 Dec 2013 11:33:40 +0000 (11:33 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 19 Dec 2013 11:33:40 +0000 (11:33 +0000)
Various fixes and small enhancements as well as the return of the
fakeonline module (now known as modules_online).

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 39136

net/znc/Makefile
net/znc/patches/001-move_rootcheck_after_config.patch
net/znc/patches/002-Uclibcpp_build_fix.patch
net/znc/patches/003-Reduce_rebuild_time.patch

index 6de485dcea748ba4c0b379514eeb49ceaef59e0e..775a394792ff210e1c3318995d3c9d828cbdd7f3 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=znc
-PKG_VERSION:=1.0
+PKG_VERSION:=1.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://znc.in/releases \
                http://znc.in/releases/archive
-PKG_MD5SUM:=23807ca830c27392cccb6774f542df6e
+PKG_MD5SUM:=ef18e5402a82cc3fcab5c2ac5c2e6f3b
 
 PKG_BUILD_PARALLEL:=1
 
@@ -25,7 +25,7 @@ define Package/znc/default
   CATEGORY:=Network
   TITLE:=ZNC
   URL:=http://en.znc.in/
-  MAINTAINER:=Jonas Gorski <jonas.gorski+openwrt@gmail.com>
+  MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 endef
 
 define Package/znc
@@ -205,6 +205,9 @@ $(eval $(call module,listsockets,This module displays a list of all open \
 
 $(eval $(call module,log,Log conversations to file.))
 
+$(eval $(call module,modules_online,This module fakes the online status of \
+       ZNC-*users.))
+
 $(eval $(call module,nickserv,Auths you with NickServ.))
 
 $(eval $(call module,notes,This modules stores and displays short notes using \
index f3f129c562e7684dd5568826831727c2e33f1ba7..8b3e3e703780e67eb7885f400bb6e60a5d4d2bbd 100644 (file)
@@ -9,9 +9,9 @@ Subject: [PATCH] Move the root check to after config parsing
 
 --- a/src/main.cpp
 +++ b/src/main.cpp
-@@ -211,19 +211,6 @@ int main(int argc, char** argv) {
+@@ -243,19 +243,6 @@ int main(int argc, char** argv) {
+               CUtils::PrintStatus(true, "");
        }
- #endif
  
 -      if (isRoot()) {
 -              CUtils::PrintError("You are running ZNC as root! Don't do that! There are not many valid");
@@ -29,7 +29,7 @@ Subject: [PATCH] Move the root check to after config parsing
        if (bMakeConf) {
                if (!pZNC->WriteNewConfig(sConfig)) {
                        delete pZNC;
-@@ -244,6 +231,20 @@ int main(int argc, char** argv) {
+@@ -276,6 +263,20 @@ int main(int argc, char** argv) {
                return 1;
        }
  
index a33707e149654ae29023a016fbb431a68f97c98d..df27c80cc0371817f1e03282595dc7120d883507 100644 (file)
@@ -9,21 +9,17 @@ Subject: [PATCH] Add a uClibc++ build workaround
 
 --- a/modules/webadmin.cpp
 +++ b/modules/webadmin.cpp
-@@ -15,9 +15,11 @@
- #include <znc/Listener.h>
+@@ -20,6 +20,7 @@
  #include <znc/IRCNetwork.h>
  #include <znc/IRCSock.h>
-+#include <string>
- #include <sstream>
- #include <utility>
  
 +using std::string;
  using std::stringstream;
  using std::make_pair;
  using std::set;
-@@ -55,7 +57,7 @@ class CWebAdminMod : public CGlobalModul
+@@ -75,7 +76,7 @@ class CWebAdminMod : public CModule {
  public:
-       GLOBALMODCONSTRUCTOR(CWebAdminMod) {
+       MODCONSTRUCTOR(CWebAdminMod) {
                VPair vParams;
 -              vParams.push_back(make_pair("user", ""));
 +              vParams.push_back(make_pair((string)"user", (string)""));
index d4ea4cd127d655f7e094755edb3b9059314dcaa3..25c08e5b3b7f83bb569ee9b03b863bedc4c77b27 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
 
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -96,7 +96,7 @@ clean:
+@@ -104,7 +104,7 @@ clean:
  distclean: clean
        rm -rf $(DISTCLEAN)
  
@@ -21,7 +21,7 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
        $(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MD -MF .depend/$*.dep -MT $@
 --- a/modules/Makefile.in
 +++ b/modules/Makefile.in
-@@ -114,12 +114,12 @@ install_datadir:
+@@ -117,12 +117,12 @@ install_datadir:
  clean:
        rm -rf $(CLEAN)
  
@@ -33,6 +33,6 @@ Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
  
 -%.so: %.o Makefile
 +%.so: %.o
-       $(E) Linking module $(notdir $(basename $@))...
+       $(E) "Linking  module" $(notdir $(basename $@))...
        $(Q)$(CXX) $(MODFLAGS) $(LDFLAGS) $(MODLINK) -o $@ $< $($(notdir $(basename $@))LDFLAGS) $(LIBS)