[packages] vncrepeater libc++ fix
authorJohn Crispin <john@openwrt.org>
Sat, 4 Aug 2012 17:02:08 +0000 (17:02 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 4 Aug 2012 17:02:08 +0000 (17:02 +0000)
SVN-Revision: 32980

net/vncrepeater/Makefile

index c48ecff9ed2f0f046f91834c6114c4fafd010db4..e1f89ff3003c8eef591e2df4b073a0005df6c2c5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vncrepeater
 PKG_VERSION:=0.12
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.rit.edu/~reh5586/openwrt/packages/vncrepeater/src
@@ -17,12 +17,13 @@ PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 
 PKG_BUILD_PARALLEL:=1
 
+include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/vncrepeater
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+uclibcxx
+  DEPENDS:=$(CXX_DEPENDS)
   TITLE:=UltraVNC repeater for Linux
   URL:=http://www.uvnc.com/addons/repeater.html
 endef
@@ -42,8 +43,8 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
-               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -lc -luClibc++ -lc $(LIBGCC_S)" \
+               CC="$(TARGET_CXX)" \
+               CFLAGS="$(TARGET_CPPFLAGS) -fno-rtti" \
                repeater \
        )
 endef