remove large parts of c99 math support in uclibc (not needed for any of our packages...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 7 Nov 2005 19:49:08 +0000 (19:49 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 7 Nov 2005 19:49:08 +0000 (19:49 +0000)
SVN-Revision: 2389

openwrt/toolchain/uClibc/files/config.mips
openwrt/toolchain/uClibc/patches/100-gcc4_fix.patch [new file with mode: 0644]
openwrt/toolchain/uClibc/patches/110-inet6_hosts_resolve.patch [new file with mode: 0644]
openwrt/toolchain/uClibc/patches/120-more_standard_math.patch [new file with mode: 0644]
openwrt/toolchain/uClibc/patches/gcc4.0-fix.patch [deleted file]
openwrt/toolchain/uClibc/patches/inet6_hosts_resolve.patch [deleted file]

index 32859af165b0a128801412c24f709b5998bd8392..9a7ca50854bda4a80a02145fa80c3e29747c04fe 100644 (file)
@@ -40,7 +40,7 @@ ARCH_LITTLE_ENDIAN=y
 ARCH_HAS_MMU=y
 UCLIBC_HAS_FLOATS=y
 HAS_FPU=y
-DO_C99_MATH=y
+# DO_C99_MATH is not set
 WARNINGS="-Wall"
 KERNEL_SOURCE="./toolchain_build_mipsel/linux"
 C_SYMBOL_PREFIX=""
diff --git a/openwrt/toolchain/uClibc/patches/100-gcc4_fix.patch b/openwrt/toolchain/uClibc/patches/100-gcc4_fix.patch
new file mode 100644 (file)
index 0000000..1dd50ce
--- /dev/null
@@ -0,0 +1,23 @@
+diff -urN uClibc-0.9.27.old/ldso/include/ldso.h uClibc-0.9.27.dev/ldso/include/ldso.h
+--- uClibc-0.9.27.old/ldso/include/ldso.h      2005-01-12 08:59:21.000000000 +0100
++++ uClibc-0.9.27.dev/ldso/include/ldso.h      2005-04-29 17:44:05.000000000 +0200
+@@ -42,8 +42,6 @@
+ extern char *_dl_preload;              /* Things to be loaded before the libs */
+ extern char *_dl_ldsopath;             /* Where the shared lib loader was found */
+ extern const char *_dl_progname;       /* The name of the executable being run */
+-extern unsigned char *_dl_malloc_addr; /* Lets _dl_malloc use the already allocated memory page */
+-extern unsigned char *_dl_mmap_zero;   /* Also used by _dl_malloc */
+ extern int _dl_secure;                 /* Are we dealing with setuid stuff? */
+ extern size_t _dl_pagesize;            /* Store the page size for use later */
+ extern const char *_dl_progname;       /* The name of the shared library loader */
+diff -urN uClibc-0.9.27.old/libc/stdlib/malloc-standard/free.c uClibc-0.9.27.dev/libc/stdlib/malloc-standard/free.c
+--- uClibc-0.9.27.old/libc/stdlib/malloc-standard/free.c       2005-01-12 08:59:21.000000000 +0100
++++ uClibc-0.9.27.dev/libc/stdlib/malloc-standard/free.c       2005-04-29 17:46:43.000000000 +0200
+@@ -16,6 +16,7 @@
+ #include "malloc.h"
++static int __malloc_trim(size_t pad, mstate av);
+ /* ------------------------- malloc_trim -------------------------
+   malloc_trim(size_t pad);
diff --git a/openwrt/toolchain/uClibc/patches/110-inet6_hosts_resolve.patch b/openwrt/toolchain/uClibc/patches/110-inet6_hosts_resolve.patch
new file mode 100644 (file)
index 0000000..fd1aaa1
--- /dev/null
@@ -0,0 +1,24 @@
+diff -urN uClibc-0.9.27.old/libc/inet/resolv.c uClibc-0.9.27/libc/inet/resolv.c
+--- uClibc-0.9.27.old/libc/inet/resolv.c       2005-01-12 08:59:21.000000000 +0100
++++ uClibc-0.9.27/libc/inet/resolv.c   2005-04-04 22:14:38.000000000 +0200
+@@ -2029,7 +2029,7 @@
+               int old_errno = errno;  /* Save the old errno and reset errno */
+               __set_errno(0);                 /* to check for missing /etc/hosts. */
+-              if ((i=__get_hosts_byname_r(name, AF_INET, result_buf,
++              if ((i=__get_hosts_byname_r(name, AF_INET6, result_buf,
+                                                                       buf, buflen, result, h_errnop))==0)
+                       return i;
+               switch (*h_errnop) {
+diff -urN uClibc-0.9.27.old/libc/inet/resolv.c uClibc-0.9.27/libc/inet/resolv.c
+--- uClibc-0.9.27.old/libc/inet/resolv.c       2005-04-04 22:16:54.000000000 +0200
++++ uClibc-0.9.27/libc/inet/resolv.c   2005-04-04 22:46:59.000000000 +0200
+@@ -1513,7 +1513,7 @@
+               } else {
+                       DPRINTF("Error\n");
+                       ret=TRY_AGAIN;
+-                      break; /* bad ip address */
++                      continue; /* bad ip address, ignore */
+         }
+         
+               if (action!=GETHOSTENT) {
diff --git a/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch b/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch
new file mode 100644 (file)
index 0000000..9f659c7
--- /dev/null
@@ -0,0 +1,11 @@
+--- uClibc.old/libm/Makefile   2005-01-12 08:59:21.000000000 +0100
++++ uClibc.dev/libm/Makefile   2005-11-07 17:24:37.155983750 +0100
+@@ -78,6 +78,8 @@
+        s_finite.c
+ # We'll add sqrtf to avoid different configurations of libstdc++.
+ CSRC+= w_sqrtf.c
++# extra stuff required for some apps
++CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c 
+ endif
+ COBJS=$(patsubst %.c,%.o, $(CSRC))
+ OBJS=$(COBJS)
diff --git a/openwrt/toolchain/uClibc/patches/gcc4.0-fix.patch b/openwrt/toolchain/uClibc/patches/gcc4.0-fix.patch
deleted file mode 100644 (file)
index 1dd50ce..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -urN uClibc-0.9.27.old/ldso/include/ldso.h uClibc-0.9.27.dev/ldso/include/ldso.h
---- uClibc-0.9.27.old/ldso/include/ldso.h      2005-01-12 08:59:21.000000000 +0100
-+++ uClibc-0.9.27.dev/ldso/include/ldso.h      2005-04-29 17:44:05.000000000 +0200
-@@ -42,8 +42,6 @@
- extern char *_dl_preload;              /* Things to be loaded before the libs */
- extern char *_dl_ldsopath;             /* Where the shared lib loader was found */
- extern const char *_dl_progname;       /* The name of the executable being run */
--extern unsigned char *_dl_malloc_addr; /* Lets _dl_malloc use the already allocated memory page */
--extern unsigned char *_dl_mmap_zero;   /* Also used by _dl_malloc */
- extern int _dl_secure;                 /* Are we dealing with setuid stuff? */
- extern size_t _dl_pagesize;            /* Store the page size for use later */
- extern const char *_dl_progname;       /* The name of the shared library loader */
-diff -urN uClibc-0.9.27.old/libc/stdlib/malloc-standard/free.c uClibc-0.9.27.dev/libc/stdlib/malloc-standard/free.c
---- uClibc-0.9.27.old/libc/stdlib/malloc-standard/free.c       2005-01-12 08:59:21.000000000 +0100
-+++ uClibc-0.9.27.dev/libc/stdlib/malloc-standard/free.c       2005-04-29 17:46:43.000000000 +0200
-@@ -16,6 +16,7 @@
- #include "malloc.h"
-+static int __malloc_trim(size_t pad, mstate av);
- /* ------------------------- malloc_trim -------------------------
-   malloc_trim(size_t pad);
diff --git a/openwrt/toolchain/uClibc/patches/inet6_hosts_resolve.patch b/openwrt/toolchain/uClibc/patches/inet6_hosts_resolve.patch
deleted file mode 100644 (file)
index fd1aaa1..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urN uClibc-0.9.27.old/libc/inet/resolv.c uClibc-0.9.27/libc/inet/resolv.c
---- uClibc-0.9.27.old/libc/inet/resolv.c       2005-01-12 08:59:21.000000000 +0100
-+++ uClibc-0.9.27/libc/inet/resolv.c   2005-04-04 22:14:38.000000000 +0200
-@@ -2029,7 +2029,7 @@
-               int old_errno = errno;  /* Save the old errno and reset errno */
-               __set_errno(0);                 /* to check for missing /etc/hosts. */
--              if ((i=__get_hosts_byname_r(name, AF_INET, result_buf,
-+              if ((i=__get_hosts_byname_r(name, AF_INET6, result_buf,
-                                                                       buf, buflen, result, h_errnop))==0)
-                       return i;
-               switch (*h_errnop) {
-diff -urN uClibc-0.9.27.old/libc/inet/resolv.c uClibc-0.9.27/libc/inet/resolv.c
---- uClibc-0.9.27.old/libc/inet/resolv.c       2005-04-04 22:16:54.000000000 +0200
-+++ uClibc-0.9.27/libc/inet/resolv.c   2005-04-04 22:46:59.000000000 +0200
-@@ -1513,7 +1513,7 @@
-               } else {
-                       DPRINTF("Error\n");
-                       ret=TRY_AGAIN;
--                      break; /* bad ip address */
-+                      continue; /* bad ip address, ignore */
-         }
-         
-               if (action!=GETHOSTENT) {