mariadb: bump to 10.2.22 8185/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Mon, 11 Feb 2019 20:49:20 +0000 (21:49 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Mon, 11 Feb 2019 20:49:22 +0000 (21:49 +0100)
From upstream release notes:

- Backport Information Schema CHECK_CONSTRAINTS Table.
- MDEV-17475: Maximum value of table_definition_cache is now 2097152.
- InnoDB ALTER TABLE fixes: MDEV-16499, MDEV-18186, MDEV-18237, MDEV-18222,
  MDEV-18256, MDEV-18016, MDEV-16849
- Mariabackup fixes: MDEV-18185, MDEV-18201, MDEV-18194
- Galera crash recovery fix: MDEV-15740
- Encryption fixes: MDEV-18129, MDEV-18183, MDEV-18279
- Fixes for the following security vulnerabilities:
  - CVE-2019-2510
  - CVE-2019-2537

OpenWrt notes:
- OpenSSL patch dropped as issue fixed upstream

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
utils/mariadb/Makefile
utils/mariadb/patches/100-fix_hostname.patch
utils/mariadb/patches/200-openssl-deprecated.patch [deleted file]

index 89d92fa55f6c0c95ada612f7292886215b58c7c3..cd153d0b11181514a5172fb6532512a89801e430 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mariadb
-PKG_VERSION:=10.2.21
+PKG_VERSION:=10.2.22
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -18,7 +18,7 @@ PKG_SOURCE_URL := \
        https://ftp.yz.yamagata-u.ac.jp/pub/dbms/mariadb/$(PKG_NAME)-$(PKG_VERSION)/source \
        https://downloads.mariadb.org/interstitial/$(PKG_NAME)-$(PKG_VERSION)/source
 
-PKG_HASH:=637f0808b65ec06902897a2f885a60377828d019d35802402dca541f8113536c
+PKG_HASH:=42f4c54c29b7c196bd105bbf4d2ea721f869b14cb7ba436c3566e6dd2760614c
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 PKG_LICENSE:=GPL-2.0 LGPL-2.1
 PKG_LICENSE_FILES:=COPYING libmariadb/COPYING.LIB
index 829b98fb287242d0208fa7579351c528c91c3562..d428a7b7e65a874d99717ab179aa28626d982119 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/mysql_install_db.sh
 +++ b/scripts/mysql_install_db.sh
-@@ -388,7 +388,7 @@ fi
+@@ -399,7 +399,7 @@ fi
  
  
  # Try to determine the hostname
diff --git a/utils/mariadb/patches/200-openssl-deprecated.patch b/utils/mariadb/patches/200-openssl-deprecated.patch
deleted file mode 100644 (file)
index 2e49918..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/libmariadb/libmariadb/secure/openssl.c
-+++ b/libmariadb/libmariadb/secure/openssl.c
-@@ -419,8 +419,10 @@ void ma_tls_end()
-     if (mariadb_deinitialize_ssl)
-     {
- #ifndef HAVE_OPENSSL_1_1_API
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10000000L
-       ERR_remove_state(0);
-+#else
-+      ERR_remove_thread_state(NULL);
- #endif
-       EVP_cleanup();
-       CRYPTO_cleanup_all_ex_data();