python,python3: apply PKG_FIXUP:=autoreconf 5071/head
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 6 Nov 2017 16:05:14 +0000 (18:05 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 6 Nov 2017 16:06:02 +0000 (18:06 +0200)
Should hopefully provide more consistent results
across distros.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python/Makefile
lang/python/python3/Makefile

index 03cda5ce984c0343a5d03aa73d668d3073ac372a..232f4bffcbef0bd5eb0e8109f71dd5f805c05e60 100644 (file)
@@ -14,7 +14,7 @@ PKG_NAME:=python
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
 # XXX: reset PKG_RELEASE to 1 only if Python's pip & setuptools versions have also bumped;
 #      otherwise, keep bumping PKG_RELEASE
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
@@ -29,6 +29,7 @@ include ./files/python-host.mk
 # For PyPackage
 include ./files/python-package.mk
 
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1
index 01f89981c08683809391b9429db6c00284c38212..9253c9688d956f845c56b3c0077e6f6aa449dd70 100644 (file)
@@ -32,6 +32,7 @@ include ./files/python3-host.mk
 # For Py3Package
 include ./files/python3-package.mk
 
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 HOST_BUILD_PARALLEL:=1