kamailio-5.x: add CPPFLAGS to CFLAGS
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 13:02:36 +0000 (14:02 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 13:02:39 +0000 (14:02 +0100)
Pass CPPFLAGS in the CFLAGS as otherwise the build system will ignore
them.

This way FORTIFY_SOURCE headers are passed to the compiler.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/kamailio-5.x/Makefile

index a8d099de441462128b0cb60c2ce6d16a57e6b348..b9531b1ab4dbab873b257073a5328e4142b13f99 100644 (file)
@@ -121,7 +121,7 @@ PKG_MAKE_ARGS:= \
        cfg_target:=/etc/kamailio/ \
        TLS_HOOKS=1 \
        extra_defs="-DUSE_PTHREAD_MUTEX " \
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LOCALBASE="$(STAGING_DIR)/usr" \
        SYSBASE="$(STAGING_DIR)/usr" \
        PCREDEFS:="$(TARGET_CPPFLAGS)" \