Merge pull request #3828 from pprindeville/fix-perl-cgi2
authorHannu Nyman <hannu.nyman@iki.fi>
Thu, 12 Jan 2017 20:35:00 +0000 (22:35 +0200)
committerGitHub <noreply@github.com>
Thu, 12 Jan 2017 20:35:00 +0000 (22:35 +0200)
perl-cgi: bump package release because of PKG_LEAVE_COMMENTS

net/bind/Makefile
net/https-dns-proxy/Makefile
net/https-dns-proxy/files/https_dns_proxy.init
net/mosquitto/Makefile
utils/gnupg/Makefile

index 19614b7f02afacab39f22333adb12f29f83743de..a4a8b851065ff9a50dceb1acf27e87564ee9dcd6 100644 (file)
@@ -9,8 +9,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.10.4-P4
-PKG_RELEASE:=3
+PKG_VERSION:=9.10.4-P5
+PKG_RELEASE:=1
 USERID:=bind=57:bind=57
 
 PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>
@@ -20,7 +20,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=e110904a1d54f83f01d4be8bcd842927
+PKG_MD5SUM:=c53a3e34e7aabb16820b036ae9afd3c9
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
index 2ebec2bd869786915b36ed285dc53f9b6be0a473..42e154ce705a3293c8f485ec6385faf2d6bfd8cc 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=https_dns_proxy
 PKG_VERSION:=2017-01-07
-PKG_RELEASE=1
+PKG_RELEASE=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
index df1b220455a95b29c66e263949acf7ba2690f475..333f3cac3ecb14914331c41fddf5782cbc8957c3 100644 (file)
@@ -16,7 +16,7 @@ start_instance() {
 
        procd_open_instance
        procd_set_param command ${PROG} \
-               -l "$listen_addr" -p "$listen_port" \
+               -a "$listen_addr" -p "$listen_port" \
                -u "$user" -g "$group"
        procd_set_param respawn
        procd_close_instance
index 08c037dc116f94b4aa17ec30470fdee10852b659..94a0298c15929efda0cd4010326234b9a9c1f96b 100644 (file)
@@ -209,7 +209,7 @@ define Package/libmosquittopp/install
 endef
 
 # Applies to all...
-MAKE_FLAGS += WITH_DOCS=no
+MAKE_FLAGS += WITH_DOCS=no UNAME=Linux
 ifeq ($(BUILD_VARIANT),nossl)
        MAKE_FLAGS += WITH_TLS=no WITH_WEBSOCKETS=no
 else
index cd1a6919d7f3fbb2f6093b69cd4accac7742f025..62b52d6c49cdd80c841f6d00de02a5e126bbeb28 100644 (file)
@@ -8,17 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.20
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.21
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=b7af897a041c03c8ad1c7c466b54d10d
+PKG_MD5SUM:=9bdeabf3c0f87ff21cb3f9216efdd01d
+PKG_HASH:=6b47a3100c857dcab3c60e6152e56a997f2c7862c1b8b2b25adf3884a1ae2276
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
-PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+PKG_MAINTAINER:=Daniel Dickinson <lede@cshore.thecshore.com>
 
 PKG_INSTALL:=1
 
@@ -38,6 +39,11 @@ define Package/gnupg
   MENU:=1
 endef
 
+define Package/gpgv
+  $(call Package/gnupg/Default)
+  TITLE:=GnuPG signature verification only
+endef
+
 define Package/gnupg-utils
   $(call Package/gnupg/Default)
   DEPENDS:=gnupg +libcurl
@@ -54,6 +60,13 @@ define Package/gnupg/description
  with PGP2 because it uses IDEA (which is patented worldwide).
 endef
 
+define Package/gpgv/description
+ GPGv is a stripped down version of GnuPG that only checks signatures.
+ .
+ GnuPG does not use any patented algorithms so it cannot be compatible
+ with PGP2 because it uses IDEA (which is patented worldwide).
+endef
+
 define Package/gnupg-utils/description
  Key management utilies for GnuPG.
  This package is needed to import keys from a keyserver.
@@ -79,6 +92,11 @@ define Package/gnupg/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpg $(1)/usr/bin/
 endef
 
+define Package/gpgv/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpgv $(1)/usr/bin/
+endef
+
 define Package/gnupg-utils/install
        $(INSTALL_DIR) $(1)/usr/lib/gnupg
        for file in gpgkeys_curl gpgkeys_hkp; do \
@@ -88,4 +106,5 @@ define Package/gnupg-utils/install
 endef
 
 $(eval $(call BuildPackage,gnupg))
+$(eval $(call BuildPackage,gpgv))
 $(eval $(call BuildPackage,gnupg-utils))